Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a weird issue with my new laptop (Asus N76VM). Every time I open iTunes it makes my DVD drive make a spin up noise for a second and then stops. It seems like it checks if there's a CD present or so (but there isn't, it's empty). I would be able to live with it if it just occurs on iTunes startup. This is not the case, even if iTunes is minimized and then I open the iTunes window again, the DVD drive spins again. This is very annoying. What could be the reason for the spinning? How can I stop it?

Note: this problem is both when running on battery or power cable.

share|improve this question
is there a CD present? – JoshP Oct 30 '12 at 13:00
Sorry, forgot to mention there isn't any CD/DVD present in the drive. – EsTeGe Oct 30 '12 at 13:06
My suggestion until you find a fix is to open the drive tray of your laptop. The good news is, it won't open very far so you'll barely notice that it's open. The bad news is, you could damage the tray bumping the machine, for instance. – user3463 Oct 30 '12 at 15:52
That was my temporary "fix" too, but I'd like to find the cause. Still no luck so far. – EsTeGe Oct 30 '12 at 20:09

I know I'm dredging up an old topic, but I think I've found the solution.

In preferences, under advanced, turn off the "Keep iTunes Media Folder Organized" selection. It is when this action is performed (at startup, shutdown, and various times when iTunes is running) that your CD/DVD drive is accessed.

share|improve this answer
I'll definitely check this out, thanks. – EsTeGe Nov 26 '12 at 22:18
Too bad, this didn't fix the issue for me. – EsTeGe Nov 26 '12 at 22:28
Not at all? I found that I'd still get it SOMETIMES when starting iTunes, but never after that, including shutting down, minimizing, restoring, etc. So, it may not fix the issue completely, but it may greatly reduce it. – J_T Nov 26 '12 at 22:34
I disabled the option, minimized iTunes for a minute, maximized it again, but the drive spinned up again. – EsTeGe Nov 27 '12 at 16:39

Well, I would suggest you check if there is anything on your iTunes, that will try to display content of a CD/DVD you used in the past.

Usually it is tied to this.

When some application wants to display CD/DVD content, it checks, if there is one.

If you need further advice, please post a screenshot of your iTunes, after refocusing on it - which than would have had spinned your drive.

share|improve this answer

My best guess is it has something to do with checking CD metadata. I.e: Track names, checking if it is an audio CD, and all that jazz. I am unsure of an explicit fix, or even if one exists, but have a look in the settings for something along those lines.

share|improve this answer

I just downloaded iTunes 11, and that seems to have fixed the problem for me completely. My previous answer worked more or less for me, even if it didn't help EsTeGe (sad face). It didn't prevent the INITIAL access, but did prevent subsequent ones. iTunes 11 doesn't even access my drive initially, so, for me at least, this issue was completely solved by upgrading. You might give it a shot.

share|improve this answer
The latest iTunes indeed appears to have solved the issue. The drive spin isn't completely gone, but it's a lot less irritating. – EsTeGe Dec 3 '12 at 18:45

I had this problem and believe I've found a solution.

I tried reinstalling iTunes and a number of other tactics. I uninstalled Daemon Tools Lite and that seemed to fix it for a while, but then the problem came back. Finally I uninstalled Intel Rapid Storage Technology and I haven't had the problem now for at least a week.

Hope this helps anyone who comes to this old thread with the same problem.

share|improve this answer

You have to go to preferences>Store and uncheck "Share details about your library with apple".

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .