Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My mail account (IMAP) has this folder structure in Thunderbird:

  • Inbox
    • Drafts
    • Sent
    • Junk
    • Trash
    • various custom folders …

As you can see, all folders are actually sub-folders of "Inbox". However, I want all folders to be on the same level:

  • Inbox
  • Drafts
  • Sent
  • Junk
  • Trash
  • various custom folders …

At Account Settings* → **Server SettingsAdvanced…, the field "Personal namespace" has the value "INBOX/". Is this the place I need to fiddle with? Or do I have to add a value in the field "IMAP server directory" (which is empty)?

I have another hosting account at the same webhoster and there all my folders are on the same level. The only difference in the mentionend settings: "Personal namespace" has the value "". I tried to use this value in my problematic account, too, restarted TB, but it has no effect on the folders. This unproblematic account runs on a newer server version, though.

What can I do so that all folders are siblings of Inbox, not children?

share|improve this question
    
I think you probably have to change this on the server side, not in Thunderbird. In IMAP it's the server that tells the client what the hierarchical structure of the folders is. –  Celada Oct 30 '12 at 15:16
    
Can't you just drag-n-drop them in TB's folder view frame to be where you want? –  martineau Oct 30 '12 at 15:43
    
@martineau depending on the server configuration, moving the folders may change how they behave too. –  user3463 Oct 30 '12 at 15:51
    
@martineau: No, when I try to drop it before or after the Inbox, nothing happens. When I try to drop it at the account name, I get the warning: The current command did not succeed. … [ALREADYEXISTS] Mailbox already exists: INBOX/test. –  unor Oct 31 '12 at 21:07
    
@Celada: But isn't that the purpose of the mentioned configuration options? I don't necessarily want to change this on the server side; it would be sufficient if it would only work in TB locally. –  unor Oct 31 '12 at 21:08

1 Answer 1

You can edit the "IMAP Server Directory" field in Account Settings. This corrected it for me.

In Linux (should be very similar in Windows):

Edit | Account Settings | Server Settings | Advanced | IMAP Server Directory

Insert [Gmail] - with the square brackets - and restart Thunderbird.

share|improve this answer
    
What should I enter there? It’s empty currently. I’m not using GMail. –  unor Nov 13 '13 at 9:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.