Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to know how to enable 120Hz refresh rate on my monitor instead of 121Hz. Its because 3D programs need 120Hz, they do not work on 121Hz.

If I put 120Hz in the resolution settings, the screen goes black for 10 sec and then turns back on with the 121Hz rate.

I do have latest drivers for 7950. Latest drivers for monitor. Dual link DVI.

share|improve this question
What is the monitor? It sounds like it doesn't want to display that. –  Shinrai Oct 30 '12 at 14:08
I take it this is a CRT correct? Did you test the 3D program at 121Hz? The refresh rate is usually not going to be exact, just like how the frequency of a CPU or FSB is usually going to vary a couple of Hertz from what it is supposed to be. Have you tried different resolutions to see if you can get a more stable refresh rate? What about other monitor controls in your video-card’s control panel like the sync settings? –  Synetech Oct 30 '12 at 14:09
@Synetech I dont have CRT monitor ...And thats exactly the problem, the 3D program cant enable 120 HZ, it gives a black screen –  Robert Nov 1 '12 at 13:45
Wait, you are running an LCD/LED monitor at 121Hz? I have never seen an LCD/LED monitor that goes that high; they usually top out at 75Hz because they don’t need it; even 60Hz is usually more than sufficient. Again, have you tried different resolutions to see if you can get a stable 120Hz or tried altering the video-card settings? –  Synetech Nov 1 '12 at 18:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.