Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can scroll using the right touchpad scrollbar on Windows 8 Pro 64-bit? On an OEM-installed-7, I was able to scroll on my Acer Aspire 5750-6866.

I tried to install the Windows 7 drivers (Elantech from Acer's page as well as Synaptic) on 8, but they required .NET 3.5, which I had to install using the CLI and the original install disc. However, once I'd gotten the installer working, it told me that the platform had installed successfully but the drivers had not.

I also tried to install the Windows 7 Synaptic drivers like everybody reccommends, but this had no effect.

Is there a way to enable anything but those generic drivers that come with 8? With a 1366x768 resolution, it takes a while to move my mouse using trackpad to the right-hand corner from the left of the screen where it is usually parked. I game as well and sometimes need a scrollwheel in-game. I find myself lost without it (or at least with my productivity crippled)! Help! I'm not asking for fancy tablet-like gestures, I only want right scroll.

share|improve this question
    
What brand is your touchpad? –  Xandy Oct 30 '12 at 15:00
    
Can you post a link to the drivers you tried, please? –  minitech Oct 30 '12 at 15:00
    
@Xandy Of course it came pre-installed in my laptop, so I believe either Synaptics or Elantec - Acer's documentation is not clear because I have a sub-model of the 5750. –  WindowsEscapist Oct 30 '12 at 15:39
    
@minitech Done. –  WindowsEscapist Oct 30 '12 at 15:39
    
@WindowsEscapist the thing is that even though drivers from manufacturer A tend to work with manufaturer B touchpads (because of the hardware IDs), if the driver is not of the same brand than the manufacturer you may not get "advanced" features like scrolling. Look at station-drivers.com for different brands of touchpad drivers (e.g. Synaptics, Alps, Elantech, ...). Mine is Synaptics and I'm currently using 16.2.16.2, works perfectly. Once you know the brand of your touchpad its drivers should make it work. –  Xandy Oct 30 '12 at 15:56
show 1 more comment

1 Answer

up vote 3 down vote accepted

I had the same problem, also with an Acer Aspire (5750G, I think). Windows 7 worked, Windows 8 didn't. The Synaptec drivers didn't solve it, but the Elantech ones did. On the Acer site, you can find the drivers for your model. Mine included both the Synaptec and Elantech ones.

After trying the Synaptec ones, I uninstalled them, and installed the Elantech ones. This did the trick.

Also, your installation of .NET 3.5 seems strange. You can get a normal installer from Microsoft.

share|improve this answer
    
I also tried Elantech before I had .NET installed (if was quite a bit of work and then I couldn't find my install DVD). I will see if it will install properly this time. –  WindowsEscapist Oct 30 '12 at 15:29
    
.NET 3.5 can be installed under Windows 8 via the CLI or by enabling it in preferences or in a program that needs it - both of which will bring up a dialogue box that asks you to download it from Windows Update. This is the same dialogue box that the "normal installer" brings up. (Incidentally, I have no idea why Microsoft would want to not include .NET 2 and 3.5 when it has 4.5 - so many things depend on 2 and 3.5, it makes no sense to get rid of them.) –  WindowsEscapist Oct 30 '12 at 15:37
    
I have about 40mins left to go on the Elantech driver (it's around 200MB), so I'll get back to you then. –  WindowsEscapist Oct 30 '12 at 15:38
    
Awesome. Works great. –  WindowsEscapist Oct 30 '12 at 19:02
1  
Nope; they still ask for 3.5 and return strange glitches. –  WindowsEscapist Nov 1 '12 at 0:24
show 3 more comments

protected by Community Dec 22 '12 at 9:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.