Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

With two Windows 8 PCs not on a domain, with a common Microsoft account present on each, it is easy to Remote Desktop between the two. The correct username is filled in for you; only the Microsoft account password is needed, which you can save.

The problem is that even if you save the password, it doesn't get used on later connections. A "Windows Security" dialog box appears, prompting "The credentials that were used to connect to Computer did not work. Please enter new credentials." At the bottom of the dialog is the error "The logon attempt failed".

The workaround is to reenter the password, but what is the solution to avoid the need to do so?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Make sure a HomeGroup isn't causing Windows credentials to be saved with Enterprise persistence.

Specifically, these steps resolved the problem:

  1. On each computer, leave the HomeGroup if on one.

  2. From the client computer, search Settings for "Manage Windows Credentials", and delete all credentials related to the other computer. (In particular, you may notice a credential TERMSRV/ComputerName that has Persistence set to enterprise.)

share|improve this answer
    
Is it not possible at all to both use the HomeGroup feature and RDP at the same time?? –  s_a Mar 11 '13 at 22:58

I'm not 100% sure about this solution since it was in Windows 7 but trying won't hurt.

The Local Group Policy Editor dialog box displays. In the tree in the left pane, navigate to the following item:

User Configuration | Administrative Templates | Windows Components | Remote Desktop Services

Select the Remote Desktop Connection Client item under Remote Desktop Services. In the Setting list on the right, double-click on the Do not allow passwords to be saved setting.

enter image description here

On the dialog box that displays, select the Disabled radio button.

Make sure to click disable for this one.

Click OK to close the dialog box for the Do not allow passwords to be saved setting.

enter image description here

To close the Local Group Policy Editor dialog box, select Exit from the File menu.

enter image description here

Credits: HelpDeskGeek

share|improve this answer
    
There is an easier way to do this without changing Local policies. Will create new answer when I get home and can make Screenshots. –  Jared Tritsch Oct 30 '12 at 20:39
    
Unfortunately, disabling "Do not allow passwords to be saved" in the Group Policy had no effect. –  Edward Brey Nov 3 '12 at 13:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.