Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to change my speaker setup and every time I click "test" I get this error message on Windows 7 SP1. I tried running "sndvol" to view the applications list but the list is empty.

Since I tried to test the new speaker setup, I'm now left without sound for all applications and can't get sound even if I switch back.

I have not updated my sound drivers so I don't know what could have changed.

What could be causing this?

share|improve this question
    
I may know what could be causing it, but I don't think I know a way of fixing it. There's an audio API called WASAPI from Windows Vista on, and one of the things applications can request when using it is exclusive sound access. If one such application is running you wouldn't hear sound form the others even if they were playing something. – Xandy Oct 30 '12 at 21:26
    
@anot - Question isn't about Windows 8, Windows 8.1, Windows 10,0 it is specifically about Windows 7, so #windows is not an appropriate tag. – Ramhound Jan 22 at 21:10
up vote 33 down vote accepted

I had the same error on Windows 7 and managed to fix it by simply restarting the Windows Audio service. If it doesn't work, disable and re-enable the sound device using device manager.

share|improve this answer
2  
Thanks, since today (Windows 8.1), everything seems to suddenly stop playing sound, or refusing to play out of my headphones (instead wanting to play out of my TV or optical which isn't even in use), disabling my headphones did nothing, usually had to re-plug them. Restarting Windows Audio seems to have fixed it. – Someguy123 Aug 20 '15 at 17:33

In the properties of your audio device, there should be a checkbox option labelled "Allow applications to take exclusive control of this device". IIRC it is enabled by default; disabling it and rebooting should resolve your issue.

share|improve this answer
1  
Thanks! This solved my problem in Windows 8. – Caleb Jares Jan 3 '13 at 18:31
    
Same here but I wish I could figure out what program suddenly started taking exclusive control. Kind of makes me worry about malware – andrewtweber Jul 16 '14 at 22:43
2  
This actually isn't working for me. It appeared to work once, but even with that disabled, some program is still taking control of them. Any ideas on how to identify which program is the culprit? – andrewtweber Jul 18 '14 at 3:26
1  
Odd, I'm also getting the same lock even after disabling the exclusive control – DWils Aug 31 '15 at 5:53

I had the same problem, and I solved it by installing an update (Chipset_Intel_Win_8) from the Asus website. I have an Asus RS51.

share|improve this answer
    
Please leave a comment if you vote down. – pelms Nov 12 '14 at 11:16

Best to combine both answers here.

As a resolution for now, execute in elevated prompt

net stop "AudioSrv" && net start "AudioSrv"

This restarts the Windows Audio Service. (Reboot will also work.)

To prevent future problems, disallow apps to get exclusive control to the device by going to sound -> (select device from list) -> properties -> advanced -> Allow applications to take exclusive control of this device .

share|improve this answer
    
Already did that, but even without that settings it still says the device is in use. Seems to happen after a while though, and it's the HDMI out on my AMD GPU. – m-p-3 Jan 8 at 16:46
    
Same problem here as m-p-3. Happens as soon as the computer has booted, on HDMI output for my AMD Graphics Card – Teocali Jan 9 at 11:06
    
Ok, found a solution : Uninstall Program >= Right click on AMD Catalyct control center > Change > Selected custom uninstallation and desinstalled the driver for the HDMI chipset. My guess is that the AMD driver was in conflict with the windows driver. I searched how to deinstall the window one to give priority to the AMD one but no luck for the moment. – Teocali Jan 9 at 11:16

protected by Community Feb 14 '14 at 4:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.