Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install the Guest Additions for Windows 8 x64 running in VirtualBox 4.2.4 OSE on a Linux x64 host. The Guest Additions installer will, every time, crash the entire VM, bringing it totally to a halt, when it attempts to install the display driver. (Go figure.) By rebooting into safe mode, I managed to get the installation to complete, but when I reboot in regular mode, the guest won't even finish booting (presumable due to the borked display driver). Does anyone know how to fix this or if there is a workaround? Any tips would be appreciated.

share|improve this question

2 Answers 2

  1. Go into the VM's Display settings and disable 3D and 2D acceleration.

  2. Set Display memory to 128M.

  3. Run the VM, login to Windows.

  4. Load IE, get the Guest Additions ISO from Oracle's FTP site [http://download.virtualbox.org/virtualbox/]. (Incidentally, IE on Metro is pretty slick. It's not the same IE as in the screen shot.)

  5. Double-click the saved ISO. Win8 can read and execute ISOs.

  6. Run the installer.

  7. The screen might go black and stay black for a while. Just be patient.

  8. After the installer finishes, shutdown Windows.

  9. Go into the VM's Display settings, and enable 3D and 2D acceleration.

  10. Restart the VM. If the video is funky, go back and disable 3D.

Source: Rich Levin

share|improve this answer
    
Hmmm. 3D acceleration makes the VM crash entirely; it's not just "funky." Do you know how to fix this? –  thirtythreeforty Oct 30 '12 at 23:31
    
Even with Guest Addition installed? –  tr4656 Oct 31 '12 at 1:27
    
Yes, with Guest Additions. To clarify: without Guest Additions, everything works swimmingly (except without Guest Additions, obviously :), but with Guest Additions, Windows won't boot all the way up if 3D accel. is enabled. With 3D disabled, it will boot. –  thirtythreeforty Nov 1 '12 at 19:24
up vote 0 down vote accepted

This seems to have been a VirtualBox bug. I can't reproduce it any more.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.