Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a local .swf file in a local .html file. The flash file opens a popup window when a link is clicked. In Chrome, when I open the html file and click the button, nothing happens. Then when I go to about:plugins and disable the top Flash player (the pepper one) then try refresh and try clicking the button again, nothing happens. Then when I go to http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html and add the the folder the files are stored in to the list and refresh the page and click the button again, it opens the popup.

When I re-enable the pepper flash player, and re-add the folder to the allowed list in flash (it's gone from the list now that I changed players), refresh the page and click the button again, it does nothing. I don't know why it won't open with the pepper player.

I'm using Windows 7, Chrome 22.0.1229.94 m, Pepper Flash player 11.4.31.110, and regular Flash Player 11,4,402,287.

share|improve this question
    
Does the flash file work in another browser such as Firefox? –  hanxue Jan 3 '13 at 15:38

2 Answers 2

You can try using the --allow-file-access-from-files parameter when launching Chrome, as explained here.

share|improve this answer
    
The --allow-file-access-from-files parameter has no effect on Flash Player's trust status, and is therefore unlikely to solve the problem. –  moock Feb 26 '13 at 21:26

As of July 2012, Chrome's PPAPI Flash Player does not support Flash Player's trusted folders. See: http://code.google.com/p/chromium/issues/detail?id=137734

You'll need to run the NPAPI player or switch to a different browser.

Here are instructions for switching to the NPAPI player: (from http://helpx.adobe.com/flash-player/kb/flash-player-google-chrome.html)

1) Download and install the appropriate system plug-in. The latest release is posted here: http://get.adobe.com/flashplayer/?fpchrome

2) Type “about:plugins” (without quotation marks) into the address bar at the top of a Chrome browser window.

3) Click “Details” at the upper-right corner of the page.

4) Find the “Flash” (or “Shockwave Flash”) listing for the integrated plug-in on the page and click the corresponding “Disable” button.

5) Find the “Flash” (or “Shockwave Flash”) listing for the system plug-in on the page and click the corresponding “Enable” button.

6) Close all Chrome windows and restart the browser.

Also, starting with Flash Player 10.3, you should use your operating system's native control panel/preferences to adjust Flash Player settings. The link: http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html applies to Flash Player 10.2 and older only.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.