Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I'm having a terrible black screen problem with my new installation of Windows 8. The screen basically goes to black every time I turn it on or sleep, or connect to an external or monitor. I dont really know what steps actually cause the problem and cant seem to figure what steps allow the screen to come back, besides forcing restarts, going to sleep and waking up, and smashing Win + P.

I have a strong feeling it's because the Switchable graphics I have (Intel HD + Radeon 5060), so I'm looking for a way to make the computer always use a specified mode (i.e the current mode I'm on, that does show stuff on the screen) and force it to use it everytime?

Any ideas?

EDIT: I've Installed all the latest drivers I've found. Tried most of the solutions around the web for this problem. Updated the BIOS to UEFI (from HP Support Assistant), etc. Laptop is an HP- Envy 14

share|improve this question
    
Have you installed the latest drivers from the manufacture? –  kobaltz Oct 31 '12 at 3:03

1 Answer 1

Having the latest drivers is always important, but to answer your question. There should be a bios setting called something like FIXED GPU, this will always keep the AMD GPU on. If you can't see it you, you may need to update your bios.

Also check out the latest beta drivers, which at teh moment live here http://support.amd.com/us/kbarticles/Pages/AMDCatalyst1211betadriver.aspx

==Edit==

Seems your bios won't let you cheat. Which version of catalyst are you running? Also try running driver Fusion to remove any of the old junk that may have accidently made its may into your installation.

Lastly, try forcing the old Windows 7 drivers, this guy did it and he seems like a cool dude: http://h30434.www3.hp.com/t5/Notebook-Display-and-Video-e-g/Windows-8-drivers-for-HP-notebooks-with-switchable-graphics/td-p/1773247/page/29

share|improve this answer
    
Didn't see that on my BIOS. –  sazpaz Oct 31 '12 at 3:19
    
Did you update the bios or are you using the latest bios? You must verify this. –  Mikhail Oct 31 '12 at 3:20
    
Yes, updated it after installing Windows 8, trying to solve this issue. –  sazpaz Oct 31 '12 at 3:22
    
Which version of the catalyst drivers are you running. You verify that you are using the bleeding edge beta drivers. –  Mikhail Oct 31 '12 at 3:27
    
I got the 12.10.I dont really know what you mean by bleed edge beta –  sazpaz Oct 31 '12 at 3:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.