Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

You'd think that kerning would be the #1 thing to get right in a text processor, but LibreOffice shows me this:

enter image description here

Font is Palatino, with bold applied.

How to fix this? Note that the kerning is correct when I un-apply bold:

enter image description here

share|improve this question
    
How is the kerning if you simply apply a bold style to the Palatino font? –  Mikhail Oct 31 '12 at 6:49
    
@Misha: sorry, I was unclear, there is only one version of the Palatino font. That's exactly what I did (apply bold to normal Palatino font). –  houbysoft Oct 31 '12 at 6:58
1  
Can you include both images of with and without boldface applied? Is there a space between m and T? –  slhck Oct 31 '12 at 8:31
    
@slhck: see edit, and yes, there's a space between the m and T. –  houbysoft Oct 31 '12 at 18:04

2 Answers 2

I must admit, I don't see the problem in your case, apart from a too narrow space, perhaps. But it could well be that the problem is just the on-screen display whereas print output looks correct. LibreOffice would just use the kerning tables from the font anyway and I guess it's very hard to get that wrong. Drawing glyphs to the screen in a pleasing manner is hard in contrast.

share|improve this answer
    
Yes, the space is way too narrow, and the letters in Problem are more far apart in the bold version than they should be. –  houbysoft Oct 31 '12 at 18:06
    
Also, it's been a while since I actually needed to print something out, I'd argue that on-screen display is equally if not more important. I certainly couldn't care less about how it looks when printed. –  houbysoft Oct 31 '12 at 18:07
    
Well, ODT is certainly not a final format you give to someone else. PDF should work the same as printed. –  Joey Oct 31 '12 at 18:46

If when you toggle Pair Kerning in Format -> Character -> Position -> Spacing, then I'd have to say it was Xft-related. What LO version are you on?

If I recall, Libre Office uses Xft settings. I've had text rendering issues with certain version of libxft, so it may be worth rolling back to an older version if it's been updated recently.

Otherwise, have you made any recent changes to .Xresources?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.