Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my vimrc I have both set number and set colorcolumn=80, so now when I open a quickfix window, I see both line numbers and the color column. Is there some way to disable these settings for quickfix windows only? (If it matters, I'm on OSX using vim 7.3).

Thanks!

share|improve this question
    
Note that line numbers may be a bit useful with cc <line-number> of <line-number>G<enter> to jump to an error you see. – Ciro Santilli 巴拿馬文件 六四事件 法轮功 Mar 23 at 22:01
up vote 6 down vote accepted

Put the following into ~/.vim/ftplugin/qf.vim:

setlocal nonumber
setlocal colorcolumn=

As long as you have filetype plugin support enabled, that should handle it.

share|improve this answer
    
Worked perfectly! Thanks. I didn't know about this, very useful. – smessing Oct 31 '12 at 6:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.