Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The inbuilt Video Player and Windows Media Player do not play any videos in Windows. I have tried in many formats. Any answers for this ?

share|improve this question
    
are you trying to play a DVD format? –  ronalchn Oct 31 '12 at 10:33
    
.avi format. I also tried .mpeg –  Divakar Raj Oct 31 '12 at 10:41
    
Note, the file extension is the format of the container, not the format of the underlying video. Maybe you are missing some codecs. Try using the VLC Player, which in my experience, has much better codec support. –  ronalchn Oct 31 '12 at 10:42
add comment

3 Answers

AVI is just a container and can contain pretty much any codec. You likely don't have the codec installed to play the file. GSpot is a handy application for finding out what codec lurks within an AVI file. Also there are things like the Combined COmmunity Codec Pack which are a comprehensive package of most codecs people might need nowadays.

.mpeg files are probably MPEG-2, I guess. Support for that (along with DVD playback) was removed from Windows 8 since almost all customers never play a DVD on their Windows computer, so raising the price to include the MPEG-2 licensing costs for everyone is actually pretty stupid.

VLC should play pretty much anything you throw at it, though.

share|improve this answer
add comment

I had the same problem with Windows 8. In my case, the problem is the new ATi movility Radeon 5650 windows 8 driver. Everything related with graphics card look ok, but when you try to play a video, is is not shown. The problem comes from the video hardware acceleration and it seems to be an error of the new Windows 8 drivers.

My solution was to install my old W7 driver (provided by Sony. I have a Sony Vaio). Graphics performance is is worse, but at least I can play any video.

share|improve this answer
    
Just use a different video player and disable hardware-acceleration in it. –  Shiki Nov 1 '12 at 0:51
add comment

You are probably missing some codecs. Windows Media Player cannot play videos if the codec used to encode it is missing.

Windows Media Player in Windows 8 has dropped DVD support, to save on licensing costs.

To play the files, you can:

  • use the VLC Player, which is the easiest solution
  • download codecs so that Windows Media Player can play more formats, for example:
    • Xvid, a GPL library for MPEG-4, includes encoding
    • Combined Community Codec Pack, support for more codecs, but only for decoding (no problem if you only watch videos, and don't intend to save anything in the format)
share|improve this answer
    
One can also download the Media Center add-on ( for free until Jan 2013 ) although that doesn't include all codecs either. –  Ramhound Oct 31 '12 at 11:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.