Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Today I installed Windows Phone 8 SDK from the official site. After installing and a couple of restarts (it restarted the PC to enable Hyper-V), I opened Connectify. I use Connectify Hotspot to connect my iPod to the internet as I have an ethernet connection and no wireless router.

The problem is that now, Connectify doesn't show WiFi in Share Over. The attached screenshot shows this.

Network Devices to share over

Previously, before I installed the SDK, it would show Ethernet and Wi-Fi. I would select WiFi and share my internet. Now, this is completely screwed.

EDIT: I found out that the Microsoft Virtual Wi-Fi Miniport Driver has got disabled and I am not able to enable it again. Please advise.

Please advise on what to do

Hardware: Windows 8 Pro with Media Center, Apple MacBook Pro 9,1 15 inch Mid-2012 (non retina)

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted
+100

Hyper-V virtualises your network adapters, so each Hyper-V Virtual Ethernet Adapter maps back to one of your existing physical adapters. Changing the properties of a virtual adapter is the equivalent of changing the physical adapter that it represents (so IP addresses can be changed in that way).

To determine which is which or to de-virtualise a particular adapter, you can use the Hyper-V Manager. I'm not sure if this is enabled by default with the SDK install but it can be enabled via the Programs and Features control panel, then by clicking Turn Windows features on or off and enabling this item:

enter image description here

Once installed and run, there should be an option on the right-hand panel for Virtual Network Manager:

enter image description here

You should get a dialog like the following:

enter image description here

The red box is the list of currently virtualised network adapters for your system. By selecting these and viewing the details in the blue box you should be able to determine which is which (and it might be useful to rename them to something more useful).

If you wish to de-virtualise an adapter so it appears to Windows how it used to, click the Remove button (yellow box). Virtual machines however can no longer see it. You can always add it back in later if this is a problem.

share|improve this answer
    
From this I have found out that Wi-Fi is vEthernet #3. So without removing it from Hyper-V, can I make Connectify detect it as Wi-Fi? It thinks it is ethernet –  pratnala Nov 5 '12 at 5:51
    
Unfortunately not; all physical network interfaces are virtualised into basic network adapters. There is good reason for this - imagine that you have 2 VM's running and they both try to connect to different Wi-Fi networks at the same time: it wouldn't know what to do! If your only use of Hyper-V is for the SDK, removing it shouldn't be too much of a problem for you especially as it is not providing your internet access to the host PC. –  Graham Wager Nov 5 '12 at 10:06
    
Also, sorry for no sources but I've have been running Hyper-V on a server since the release of Windows Server 2008 so know my way around! :) –  Graham Wager Nov 5 '12 at 10:07
add comment

Go to the Computer Management (just type that in the ModernUI), then to Device Management and look for your Virtual Network Adapter in the Network Adapters. Re-enable the device if it is disabled (right-click on the adapter). Then it should work again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.