Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install Powershell 3.0 on my Windows 7 x64 SP1. Update starts, but then it says

Some updates were not installed. The following updates were not installed: Update for Windows KB2506143.

...and an option to Close. Tried rebooting to make sure there are not any locked files etc. - same problem persists. Framework 4.5 is installed with VS 2012.

I used this page to download:

Download Center - Windows Management Framework 3.0

And this file to install:

Windows6.1-KB2506143-x64.msu

Here is how it looks:

enter image description here

Troubleshooting: I tried installing on another machine, which is also Windows 7 x64 and it worked without a problem, smooth as butter. I'll try on more machines and keep this question updated.

share|improve this question
    
A downvote? O_o Is it because somebody had a bad day? –  Neolisk Oct 30 '12 at 19:36
    
Likely because of "Windows 7", even though this is probably a management workstation and likely in-scope. –  SysAdmin1138 Oct 30 '12 at 19:37
    
@sysadmin1138: It is just to get the feel of it, troubleshoot compatibility of existing scripts after they are upgraded etc. Later on the servers and other workstations will be upgraded one by one. BTW, I just thought of a good way to research this issue - see if it works on other machines. :) –  Neolisk Oct 30 '12 at 19:41
    
It probably didn't deserve a downvote but it's going to get closed. The question as written contains absolutely nothing to indicate it is anything other than an end-user question. –  John Gardeniers Oct 31 '12 at 6:42
    
@JohnGardeniers: I can include more data regarding installation on other machines - just did not have time to try it so far - I am a software developer in my company, and have other tasks. PS 3.0 is one of my hobbies. –  Neolisk Oct 31 '12 at 11:26
add comment

migrated from serverfault.com Oct 31 '12 at 14:06

This question came from our site for professional system and network administrators.

1 Answer

I just had the exact same problem.

To find out more about what went wrong, I opened Event Viewer and under 'Windows Logs' opened the 'Setup' log. The most recent error is:

Windows update "Update for Windows (KB2506143)" could not be installed because of error 2147942417 "The system cannot move the file to a different disk drive." (Command line: ""C:\Windows\system32\wusa.exe" "E:\Windows6.1-KB2506143-x86.msu" ")

In my case this error occurs because both 'Program Files' and 'ProgramData' are on my E: drive, not C:

Even though I change all possible pointers to C:\Program*, the update seems to insist on C:\ProgramData, after moving ProgramData back to C: the update succeeded.

Even if that's not your problem, there should be an error in the event log that may help.

share|improve this answer
    
+1. Thanks for your feedback - I will try your solution. My program files are standard (located on C:), but maybe there are other errors in the event log. –  Neolisk Dec 4 '12 at 21:11
    
Tried to install system readiness tool, the issue still persists. Suggested from here. –  Neolisk Dec 24 '12 at 18:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.