Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I noticed that when I turn off some of the the language input indicator in the system icons / notifications area, it doesn't save the state and turns back on on restart. Is this a known issue? What could be causing this?

Specifically what I'm referring to:

  • In notifications area, click the small arrow
  • Click Customize
  • Click "Turn system icons on or off"

enter image description here

I noticed a comment here says the change is for the session only. Why would that be intended behavior...?

How else can I turn the language input indicator off permanently? (It takes an awful lot of space).

share|improve this question
add comment

4 Answers

up vote 9 down vote accepted

Try this:

  1. Go to Control Panel → Clock, Language, and Region → Language → Advanced Settings

  2. Under "Switching Input Methods" make sure that "Use the desktop language bar when it's available" is checked

  3. Click the Options link to its right. A new window should pop up.

  4. Go to the "Language Bar" tab and set "Language Bar" to Hidden

  5. Finally hit OK and Save

share|improve this answer
    
This seems to do the trick - Enable as Hidden. –  mtone Apr 1 '13 at 13:08
add comment

Turning them off isn't session only and (for me) it stays off unless I change it back.

Maybe there is something else that is turning on your input indicator icon?

share|improve this answer
    
Interesting, I wonder what would that be. On my initial install, everything(metro apps, web page redirects, etc.) ended up in French, so I messed with settings around a bit to change it back to English (I only wanted French keyboard and French date/time formats like I'm used to in Win7). Languages are fixed, but this thing can't stay off. Hope I can figure it out without having to reinstall. –  mtone Oct 31 '12 at 15:35
add comment

As far as I remember, they fixed the "only save for this session" thing in Windows 7. If you want to get rid of it, go to Control Panel > Languages (sorry, not at a Windows PC at the moment) and delete all other languages except for your current one. If I remember rightly, there's an option there to hide the taskbar indicator off too.

share|improve this answer
    
I've already deleted extra languages (there's only one big row in Languages with the "Options" button), but I've kept 2 keyboard input languages which I need. –  mtone Oct 31 '12 at 15:38
    
Try turning it off from System Notifications again, then restarting immediately. –  Hassan Khan Nov 1 '12 at 14:11
    
Just tried that, didn't solve it. –  mtone Nov 9 '12 at 23:57
add comment

Not sure what fixed it, but after going through most language preferences and changing settings back and forth (language override, show/hide language bar, etc.) it doesn't show up anymore on boot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.