Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm seeing a really weird issue under Vista SP2 with Virtual PC. I'm trying to use an XP SP3 image to do some IE6 compatibility testing, but everytime I start up the virtual machine, the keys on my keyboard take on a mind of their own.

If I press the D key, the desktop is shown. If I press the E key, an explorer window opens. If I press the R key, the Run dialog is displayed.

This drives me crazy, I'm unable to do any work under this situation because I can't type anything without windows popping up left and right.

For clarification, I am not pressing the Windows Logo key, the control key, the shift key, or any other key in conjunction with the keys I'm pressing that cause these windows to appear.

Any ideas?

share|improve this question
    
The D, E, and R shortcuts you mentioned are done by pressing the Windows Key plus that letter...FYI. –  studiohack Nov 4 '10 at 20:05

2 Answers 2

I get this from time to time and I do not run Virtual PC.

Sometimes, if I do something after pressing a shortcut key, the special key such as shift gets stuck in the pc.

Try pressing Shift, Control, Windows Flag and Alt a few times and both sets. This usually clears it for me.

share|improve this answer
1  
Add the winkey to that list of keys! That's probably the culprit here :P –  Phoshi Oct 1 '09 at 21:35
1  
@Phoshi +1 correct!, well done! –  William Hilsum Oct 2 '09 at 8:30

This article cleared it up for me (although, it didn't solve it permanently).

In my case, I really suspect it was doing Windows Key + L, as I lock my desktop all the time during the day, and typing 'L' always messed up the remote machine.

I'm remote desktop-ing to a virtual image of Windows7 Enterprise (64-bit).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.