Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I have 3 machines, a windows 7 desktop that is always wired to my router, osX laptop, and raspberry pi running debian linux. My router is a Linksys e1000 wireless N.

My goal is to be able to ssh the raspi from any machine, while it is connected via wifi. My problem is that when trying to ssh from either the win7 or osX to the Pi it either times out, or gives an error: "ssh: connect to host 192.168.1.### port 22: No route to host"

The only times that I have managed to connect to the pi from any machine were when it connected to the router via an Ethernet cable.

Currently with win7 desktop wired, macbook wireless, and pi wireless tests give the following:

win7 ping macbook: Destination host unreachable. macbook ping win7: Request timeout. win7 ping pi: Destination host unreachable. macbook ping pi: Request timeout. blah blah blah

Plugging the macbook into the router with an Ethernet cable all communication between win7 and macbook works. Pings, ssh, ftp, smb ect...

No changes to the pi, still no connections possible to or from any of the other 2 machines.

Note All machines, are able to connect to the internet and ssh to the same machine on a completely different network, wired or over wifi.

Plugging the Pi in with Ethernet (and macbook still wired) I can ssh to the pi from both win7 and macbook. I can ssh from the pi to macbook. All machines still able to connect the the off network machine.

Also another little side note- I was playing warcraft 3 with my roommates the other day, and the only time they were able to see my LAN game was when they were plugged into the router with an Ethernet cable. Once or twice one of the laptops was able to connect over wifi, but not without another computer connecting first via Ethernet.

So basically does anyone have any info as to why my router seems to completely ignore local wireless traffic?

Edit: Network Configuration http://web.ics.purdue.edu/~achrapko/

share|improve this question
    
At the risk of asking a dumb question: are you sure that your wireless devices are using your wireless router? Is it possible that they have discovered another one in the building next door (or whatever)? Can you try looking at their routing tables? (netstat –r should work on OS X.) –  Scott Oct 31 '12 at 22:24
    
Yessir, I am sure. I did checked the AP Isolation suggestion from Calin via my laptop, and I had to manually edit a configuration file for my pi to connect to my router when it boots up. I just got home from work, and will edit my original post with all the network information from individual machines tomorrow –  AChrapko Nov 4 '12 at 4:59

2 Answers 2

Yes. It's called AP Isolation. It makes the wireless devices connected to the router be able to connect to the internet but not to each other.

Log in to your router and turn off AP Isolation.

For my Linksys it's in Wireless -> Advanced wireless settings -> Ap Isolation (Check this to Disable)

share|improve this answer
    
Thank you for the response. Unfortunately when I went to do this, mine was already Disabled by default :( –  AChrapko Oct 31 '12 at 18:33
    
can you post some information from your network? –  Calin Nov 1 '12 at 16:05
    
"ipconfig /all", "netstat -r" as suggested by Scott, for windows and "ifconfig" and "ip route" or "route" on linux / os x (first from lan, then from wireless) –  Calin Nov 1 '12 at 16:12
    
This is going to be very convoluted, and I apologize. I will edit my original post and append that info. –  AChrapko Nov 3 '12 at 19:03
    
Sorry for the delay. It looked horrible copy/pasting the output so I linked it on my university webspace –  AChrapko Nov 5 '12 at 10:03

If yours is already Disabled by default try:

With the Cisco E3000, Enable AP and save the settings, then disable AP and saving the settings again.

You should then be able to SSH into my wireless RPi from any computer connected to a home network.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.