Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When deleting certain files from the Program Files directory using the Administrator account, I got the following pop-up:

Folder Access Denied

How should I work around this? Why am I asked to require permission from "TrustedInstaller", despite using an Administrator's account?

share|improve this question
Are you trying to delete Windows.old ? – HackToHell Oct 31 '12 at 17:11
Trying to delete some files under "Program File", left after un unstallation of software. Windows.old is something left after upgrade to Windows 8 ? – A.Antri Oct 31 '12 at 17:15
Thanks for the the clarification – HackToHell Oct 31 '12 at 17:18
There were some extension files that seemed a little delete resistant, but that was solved by cutting and moving the files to my Dropbox and then deleting them from there. I suppose there could be different variations of that type of maneuver. – user190133 Jan 21 '13 at 14:03
up vote 20 down vote accepted

You need to take the ownership of this folder and recursive files:

Many times you need to take ownership of a file or folder in Windows. For example, when you want to customize Windows UI and need to replace existing system files with a new one. You have to follow no. of steps to take ownership and grant yourself full permission to access the file or folder. But now you can do it in a single step.

Basicaly, folow this steps:

  1. Enter into the folder properties: enter image description here

  2. Go to "Security" and edit(with the Advanced buttom) the "CREATOR OWNER" owner to your user: enter image description here enter image description here enter image description here enter image description here

Here you can also find a How-to video.

share|improve this answer
This did not help in my case where the Owner is showed in a link separated from Permissions, Auditing and Separate Permissions. And there was no clear way visible that could help me achieve the desired result. – MycrofD Jun 6 '15 at 16:41
@MycrofD This link might help you. Click on change in the owner tab, advanced in the next window, then find now and find your account. – Bprodz Jun 12 '15 at 19:11
If someone fancies to do the same from the command line, i.e. for batch automatization, here is (disclaimer: my) recipe: – Frank N Sep 7 '15 at 10:22

This requires a TakeOwnership registry hack. The files are in the link above.

In order to install the hack just execute the InstallTakeOwnership.reg file. Then restart the explorer.exe process. (You can do this in Task Manager) Now when you right click a file you should see an option to "Take Ownership".

Here is what it should look similar to:

enter image description here

share|improve this answer
Nice, thank you. This used to bug me all the time, the "Take Ownership" registry hack completely solves this problem! – akalucas May 2 '13 at 11:58
The URL appears to have been changed to – Hans Kesting Jan 28 '15 at 9:58
Yes. This actually helped. – MycrofD Jun 6 '15 at 16:39

TrustedInstaller is the built-in user account which Windows uses to install updates and Windows App.

The folder you're trying to open is owner by TrustedInstaller and no one else has read access. Being Administrator, you can change the permissions but only after you make yourself the owner.

If you're sure, you can become the owner and then delete the folder.

share|improve this answer

You must log in to answer this question.

protected by Community Jun 5 '13 at 20:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .