Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to not overwrite /usr/share/X11/symbols/us, even thought I've been doing that for years.

So I added to ~/xkb/jpic, a copy of dvorak-alt-intl from /usr/share/X11/symbols/us, since that's what I'm going to work on:

default
partial alphanumeric_keys
xkb_symbols "dvorak-alt-intl" {

    name[Group1]= "English (Dvorak alternative international no dead keys)";

    include "us(dvorak)"

    key <AE04> { [         9,  dollar,    EuroSign ] };

    key <AD02> { [     comma,    less,  adiaeresis,       dead_caron ] };
    key <AD03> { [    period, greater, ecircumflex,   periodcentered    ] };
    key <AD04> { [         p,       P,  ediaeresis,     dead_cedilla ] };
    key <AD05> { [         y,       Y,  udiaeresis ] };
    key <AD08> { [         c,       C,    ccedilla,    dead_abovedot ] };

    key <AC01> { [         a,       A,      agrave ] };
    key <AC02> { [         o,       O, ocircumflex ] };
    key <AC03> { [         e,       E,      eacute ] };
    key <AC04> { [         u,       U, ucircumflex ] };
    key <AC05> { [         i,       I, icircumflex ] };
    key <AC10> { [         s,       S,      ssharp ] };

    key <AB01> { [ semicolon,   colon, acircumflex ] };
    key <AB02> { [         q,       Q,  odiaeresis,      dead_ogonek ] };
    key <AB03> { [         j,       J,      egrave, dead_doubleacute ] };
    key <AB04> { [         k,       K,      ugrave ] };
    key <AB05> { [         x,       X,  idiaeresis ] };

    include "level3(ralt_switch)"
};

But this always fails:

>>> setxkbmap -v 10 -I ~/xkb/ jpic dvorak-alt-intl 
Setting verbose level to 10
locale is C
Warning! Multiple definitions of keyboard layout
         Using command line, ignoring X server
Warning! Multiple definitions of layout variant
         Using command line, ignoring X server
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      evdev
layout:     jpic
variant:    dvorak-alt-intl
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+jpic(dvorak-alt-intl)+inet(evdev)
geometry:   pc(pc104)
Error loading new keyboard description
share|improve this question

Is it acceptable for you to do this by Xmodmap?

When you run xmodmap -pke > .Xmodmap it will generate a .Xmodmap file containing your current keyboard mapping in a format like keycode 57 = n N with a line for each keycode followed by the keysyms currently mapped to it by your layout and each column corresponing to a different modifier (so in this case 'n' with no modifier and 'N' when used with shift). You can edit your layout there and just run xmodmap .Xmodmap to activate it.

A short, helpful introduction can be found here

share|improve this answer
    
It will be acceptable if an answer using setxkbmap -I doesn't show. But in that case I will report the bug in xorg. Thanks for answering. – jpic Nov 7 '12 at 12:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .