Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I do not know which one is my Ethernet Controller. It was working fine in Windows XP, but after installing Windows 7 (clean install), it is not able to detect driver for Ethernet Controller, so I am not able to connect to internet.

Looking at the other devices in Device Manager, there are several entries for Intel 82801G ICH7 family ..., so I guess that is my chipset model.

Looking at the back of the computer, there is no external network card, the lan cable is going to the motherboard provided LAN slot, so it is the integrated network adapter.

I did google search for at least 1 hour, most links are pointing to torrent sites or require me to install one of the downloader softwares, which are fraught with risk.

I went to intel download center, there also I could not find any driver for ethernet controller for the specific chipset 82801G ICH7 family.

Any help will be greatly appreciated, as I need to connect to internet from the Windows 7 machine.

Thanks.

EDIT: Looking at the Hardware Ids of the Ethernet Controller, there are 4 hardware ids:

PCI\VEN_10EC&DEV_8136&SUBSYS_813610EC&REV_03 PCI\VEN_10EC&DEV_8136&SUBSYS_813610EC

PCI\VEN_10EC&DEV_8136&CC_020000

PCI\VEN_10EC&DEV_8136&CC_0200

Why are there 4 hardware ids? I googled for the 1st hardware id. I found it belongs to "Realtek RTL8103E Family PCI-E Fast Ethernet NIC". But I could not find the driver for even that in google. As earlier, most sites are torrent sites or require their own downloader to be installed.

EDIT 2: I found that the Realtek RTL8103E driver is already included with Windows 7. But If I try to install driver manually, it says "Installing this driver is not recommended", still if I proceed and install, it says The device failed to start. I am sure my ethernet controller is fine, as it was working a few hours ago when I was on XP. It is quite confusing, as the hardware id points to Realtek RTL8103E, but driver bundled with Windows 7 does not recognize it.

I ran CPU-Z to collect details about the motherboard. The results are: Motherboard Model: OEM, Chipset: Intel P35/G33/G31, Southbridge: Intel 82801GB (ICH7/R), BIOS Brand: Phoenix Technologies, Version: 6.00 PG

When I restarted the PC, I observed the first screen which comes displays "MERCURY". I opened the PC cabinet. On the mainboard, Mercury is written. Between the CPU fan and RAM slots, there is a string "G31CCL2-07", I guess that is the motherboard model. Don't know why CPU-Z says motherboard manufacturer and model is OEM!! Searched google for G31CCL2-07. Some links are there, but they require me to download their own download managers, which is risky. Searched Mercury site for G31CCL2-07, but could not find any driver. I am running out of ideas!

I have tried RTL8103E downloaded from http://152.104.125.41/downloads/downloadsView.aspx?Langid=1&PNid=7&PFid=7&Level=5&Conn=4&DownTypeID=3&GetDown=false#RTL8100E/RTL8101E/RTL8102E-GR/RTL8103E%28L%29%3Cbr%3ERTL8102E%28L%29/RTL8101E/RTL8103T%3Cbr%3ERTL8401/RTL8401P/RTL8105E%3Cbr%3ERTL8402. But it was not recognized by Windows 7 as a valid driver.

Also tried "Win7 and WinServer 2008 R2 Driver" and "Win7 and WinServer 2008 R2 Auto Installation Program (SID:1522305)" from the list in this link: http://www.realtek.com.tw/Downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=7&Level=5&Conn=4&DownTypeID=3&GetDown=false. Does not work.

share|improve this question
    
See if one of these will work for you –  Moab Oct 31 '12 at 20:39
    
Hi! Instead of posting so many comments, could you consider editing your question, summarizing what you've found so far? This way it's easier to help you. Please make these edits substantial though. –  slhck Nov 1 '12 at 13:59
    
Done editing question. Hope it is upto mark now? –  AllSolutions Nov 1 '12 at 14:23
    
Is this the motherboard? mercury-pc.com/images/pr_mb/PIG33S_b.jpg (If it is the NIC is a Realtek 8105EL) --- " CPU-Z says motherboard manufacturer and model is OEM" That is because that is what is filled in (or rather, left at the default instead of properly filling in the right string) in the BIOS tables. –  Hennes Nov 1 '12 at 17:59
    
Hmmm..I am not sure, I don't think it is this one, I will go home and take a photo of the assembled motherboard and post it on rapidshare and share the link with you. But the motherboard model G31CCL2-07 - does it not help? –  AllSolutions Nov 2 '12 at 5:22
add comment

1 Answer

up vote 0 down vote accepted

I was able to solve the problem, by using an alternate internet connection and allowing Windows to search driver automatically. I connected my Android mobile to the PC, and used the mobile's internet connection from the PC using PDANet.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.