Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How to add a display mode to a VirtualBox VM?

I am using VirtualBox to run windows 8 while I test it out. All of my other virtual machines (i.e. Windows XP a Ubuntu) will use the full screen. For some reason I am unable to get it to fit the full screen like it should. The monitor I am using has its screen resolution set to 1600 X 900.

In the below screenshot of my XP virtual machine you can see the resolution is 1600 X 836. Which utilizes the entire screen. enter image description here

Now looking at the resolution settings in my Windows 8 virtual machine I do not have any resolution setting that is close enough to 1600 X 900. How can I get a resolution setting in the Windows 8 virtual machine that will use the monitors entire area without causing scroll bars?

enter image description here

EDIT Under the view toolbar in VirtualBox I selected Switch to Seemless Mode just to trouble shoot a little and then exited that mode. Now it is actually auto resizing the screen. However I am unable to get to the start ribbon or whatever it is called that appears on the right hand side of the screen. So, I restarted the machine and now it is really slow. Does VirtualBox have problems with guest additions working in Windows 8?

EDIT ROUND 2 Well, I un-installed and re-installed VirtualBox (the most current version). I then created the Windows 8 virtual machine again from scratch. I installed guest additions and it still is not working correctly. I have virtual machines for Windows XP, Ubuntu, Fedora, and Xubuntu and they are all working flawlessly. So far, Windows 8 has not impressed.

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, 8088, Windos, KronoS, BBlake Nov 5 '12 at 20:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What's your host OS? Are you using the latest VirtualBox version? Did you install the VirtualBox Guest Additions? –  Ƭᴇcʜιᴇ007 Oct 31 '12 at 19:14
    
I am running VirtualBox on Window 7 and I do have the latest version installed. I also have guest additions installed. –  Linger Oct 31 '12 at 19:27
    
I'm getting the same bad behavior. Also, dual monitors isn't working. I have a feeling the Windows 8 Guest Additions are half-baked right now. –  JohnB Sep 15 '13 at 4:16
add comment

2 Answers 2

up vote 4 down vote accepted

Something to try (assuming a Windows host):

  • Stop VirtualBox (all VMs).
  • Open a commnad prompt and navigate to your VirtualBox folder (something like "c:\Program Files\Oracle\VirtualBox\").
  • Run VBoxManage.exe setextradata "Your VM Name" CustomVideoMode1 1600x900x32
  • Restart your Win8 VM and check to see if the resolution is available.

More info here and here

share|improve this answer
    
I did end up re-installing the windows 8 VirtualBox machine. I added the resolution like you explained and it is working good. For some reason guest additions just was not working. Guest additions made it very buggy. –  Linger Nov 1 '12 at 12:44
add comment

It seems like you haven't installed the VBox Guest additions. Once that is installed, it should scale to any resolution automatically.

Guest additions

Do remember to restart your VM after installation.

share|improve this answer
    
I do have guest additions installed and it is not auto resizing the desktop properly. –  Linger Oct 31 '12 at 19:26
    
@Linger Try a reinstallation. Also, are you using a version of Virtualbox that gave you Windows 8 as an option during VM creation? –  DarkCthulhu Oct 31 '12 at 19:27
    
Yes I am using a version of Virtualbox that gave you Windows 8 as an option during VM creation. –  Linger Oct 31 '12 at 19:40
    
Try a reinstallation of Guest additions. Also ensure that Auto-resize display is checked in VBox. –  DarkCthulhu Oct 31 '12 at 19:42
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.