Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My USB stick has suddenly stopped working. It's a Busbi 4GB. My USB used to be G:/ but as soon as I plugged it in, I used to get a pop up box showing that it was plugged in.

Now, when I plug this in, it shows as I:/ and no pop up box appears. It shows in my computer as I:/ and when I click to open it says I:/ is not accessible the disk structure is corrupted and unreadable. I have tried to change the file name back to G:/ but nothing happened (this was under disk management).

On disk management, it shows Volume as I:/ Layout simple Type Basic File system RAW status Healthy (Active,Primary partition) Capacity 3.42GB. I've tried right clicking properties then the tab tools and click error checking (this option will check the volume for errors). When I click "check now" it comes up with the disk check could not be performed because Windows cannot access the disk.

share|improve this question
    
Sounds like a hardware error if it can't access the disk. Either rejoice because you remembered to make backups, or take a moment to understand that this is why we make backups. –  Darth Android Oct 31 '12 at 22:07
    
Did you try deleting the partition, recreating it and formatting anew using Disk Management? If it doesn't work, probably time to get a new one. –  Karan Oct 31 '12 at 22:08

2 Answers 2

File system RAW? That's not right, that's probably what the problem is. Windows probably can't read the "RAW" data. Unfortunately, the only fix for this is to format it as FAT32 (it should've been FAT32 to begin with).

However, if you have another computer with an OS or know of a download that can read raw data, then you can recover the data before formatting as FAT32 (most common file system for removable devices).

Good luck, hope this helps. If not drop a comment, and I'll look into the problem further

share|improve this answer

If the data on the USB is not that important why don't you just format the USB drive again?

Here's how to format it :

  1. Plug it to your computer .
  2. Go to 'My Computer' and right-click on the USB drive and select "Format".
  3. Select FAT32 and not NTFS as format.

If this doesn't work format it using HP USB Disk Storage Format Tool.This should fix it.

To recover the data lost on formatting, you might want to try to use one of the free recovery tools out. Reccuva is one of the best recovery tools you may try.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.