Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I boot my Windows 8 laptop (see details below), it displays this message:

Recovery

Your PC needs to be repaired

A required device isn't connected or can't be accessed.

Error code: 0xc0000225

[ A text saying I should use recovery tools on my installation media to fix the issue. ]

Press Enter to try again

Press F8 for Start-up Settings

Press Esc for UEFI Firmware Settings

If I press Enter or F8, the central part of the message changes to:

The application or operating system couldn't be loaded because a required file is missing or contains errors.

File: \Windows\system32\winload.efi

Error code: 0xc0000225

My specific situation:

I have an ASUS UX32VD (R4002H) bought just days ago with Windows 8 preinstalled. I was going to swap the internal HDD for an SSD and was messing with the partitions to make them fit into the smaller SSD before cloning. I am not sure exactly what operation I did prior to the crash, but I probably tried to move a partition (which probably was unnecessary anyway).

I have not made recovery disks (yeah, I know).

When I started SystemRescueCD on the laptop and ran testdisk (for the first time in my life), the partitions seemed OK (to my eye), except for something called Backup Boot(sector|loader|?) that was marked as Bad on one of the partitions. I fixed that, to no avail.

I have no physical representation of a serial number (is that a thing of the past?) and I don't know anything about it being somewhere on the disk. I have no installation media, I didn't get anything like that with the computer.

I have contacted ASUS support, but the answer wasn't very technical.

My obvious question:

How can I get out of this mess? I would prefer if I could repair the partition table or whatever is wrong and get back into the installed OS, but if that is not possible, how can I reinstall Windows 8?

If I need to run a system repair distro from a USB stick and run command line programs, that's no problem.

Thanks!

share|improve this question
    
FYI, the product key is on your power adapter (at least it is for my UX32VD). –  ernie Oct 31 '12 at 22:21
    
I can't find it there, and as far as I understand it from forum comments, it's not there anymore for Windows 8. Do you have a product key for Windows 8 on your power adapter? –  Peter Jaric Oct 31 '12 at 22:23
    
You can buy restore media from Acer, if you cry on the phone they might send them for free. ;-) Sorting out this kind of mess is not a good fit for SU. –  Moab Oct 31 '12 at 22:28
    
Ah, I got mine with Win7, not Win8. –  ernie Oct 31 '12 at 22:28
1  
Here's the ASUS page on using the recovery partition (hoping that that's not one that's corrupted): support.asus.com/Troubleshooting/… –  ernie Oct 31 '12 at 22:29

2 Answers 2

up vote 2 down vote accepted

Try several tools for repairing your disk, or consider restarting from scratch.

  1. chkdsk (Windows 8 DVD)
  2. Disk Utility (Mac OS X DVD)
  3. gparted (Ubuntu)
  4. ntfsfix (Ubuntu, as part of the ntfsprogs package)
  5. TestDisk (Ubuntu)
share|improve this answer
    
Either of these two suggestions seems to be the best shot. Marked as answer. –  Peter Jaric Nov 5 '12 at 12:30

I followed these instructions after resizing my Windows 8 partition (in preparation for installing Linux, resizing ntfs, then deleting and adding a new smaller partition entry) which resulted in the exact same error you got.

http://www.fixedbyvonnie.com/2013/12/how-to-repair-the-efi-bootloader-in-windows-8/

Afterwards I received a different error indicating my system needed to be repaired (this seemed marginally better), and I needed to run the "Auto-repair" option from my recovery partition. After that it booted into Windows fine.

I'm not sure what the problem was, as I mounted the resized partition and could confirm that winload.efi was indeed there. One suspicion I have is that deleting and recreating the partition entry confused the UEFI so that it had some dangling reference that didn't resolve to the new partition (and therefore could not find the winload.efi).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.