Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm currently having a Problem with my msi GT70 laptop. my laptop is running windows 8 and yesterday it requested a Restart to Update. after the Restart and the update I tried to surf the net through google chrome, the WiFi connection is perfect but the page I tried to access is not loading at all, after a while it shows failure to load page. I disabled and reenabled the WiFi chip through the device manager but still no internet connection. I uninstalled and reinstalled the drivers, still no internet. I updated the Driver of the wifi, still no internet, I even went to Wifi configuration and tried to change the DNS and reset it back to automatically, still no Luck.. I'm really lost I don't know what to do, I don't want to go deep and play with Laptop DNA "aka: registry file" and screw things up. I really appreciate any help in this matter. thanks in advance.

Note: I tried to access many pages but no luck. I even tried Firefox, Opera, even ie still no luck. The internet is working fine on my tablet and cellphone, except for the Laptop.


Okay so I connected my laptop to the modem, powered down the modem then turned it on, waited until everything is stilled no internet connection, it is like stuck in limbo trying to load the page but can't find it's way.. I reconnected the modem to the router, everything except the laptop connected to the net, I Flushed the DNS still no connection.

Note: the Previous Driver was Microsoft Drive for the WiFi, as I mentioned I did the Update the drivers to latest one.. [the Wireless route is the new Airport Express (Why in God Name did I buy it?)]

I will now attempt to Update the Ethernet and see if it will connect to the internet through it..

[Additional Information]

Internet connection is OK.

Pinging to google using its IP it responds on the act.
Pinging to google using its URL doesn't work.

Changing the DNS only works for a few seconds (really strange).
Then, exactly the same issue appears.

Somehow, the computer cannot communicate with the DNS server.


installing the qulacomm did not help.. neither connecting through the Ethernet nor the WiFi connects me to the internet..

here is a screen shot of the The Network Connection details ..

The Network Connection Details in my msi GT70

share|improve this question

migrated from Nov 1 '12 at 4:38

This question came from our site for system and network administrators.

can any other devices attached to the wireless connect to the internet? – StanK Nov 1 '12 at 4:41
can you try an ethernet cable, see if the problem is on that adapter also? – Moab Nov 1 '12 at 4:51
you might also review the updates installed by windows updates, maybe it updated a driver you can roll back. – Moab Nov 1 '12 at 4:52
Can you ping/traceroute to anything (, Is DHCP working? Are you being assigned an IP, etc? Also, maybe try flushing your dns cache: Running cmd as Admisitrator run ipconfig /flushdns – Matthew Brown Nov 1 '12 at 5:05
I'm having the same problem on Win8Pro both on Wifi and Lan on 2 different computers and via different networks. – MichaelS Nov 1 '12 at 9:15

To solve this problem, all I had to do was uninstall my internet security program and restart the computer.

share|improve this answer
I think you are the same person who asked the question? Try joining your accounts. You can also edit your original question. – S.L. Barth Nov 1 '12 at 6:13
It would also be worth mentioning the name of your "internet security program" so this might help others in future. – Austin ''Danger'' Powers Feb 27 '13 at 2:54

Try entering the DNS manually as follows:

  • Primary DNS:
  • Secondary DNS:
share|improve this answer
Are you sure the OP wants to use the Google Public DNS? – Al E. Dec 10 '12 at 14:26

Microsoft or MSI discovered the bug and updated the components that caused it.

I had exactly the same issue with a computer of the same series. Last week I updated everything and the problem disappeared.

share|improve this answer

Try this command: netsh winsock r and restart your computer.
It solved the problem in my case.

share|improve this answer

It looks like its a problem that caused by multiple networks. I've had the same issue because of LogMeIn Hamachi virtual network. I've disabled Hamachi and the problem was fixed.

I believe that if you set the secondary network (i.e Hamachi or any other) to a lower priority, it may solve the problem as well.

share|improve this answer
OP (who has lost his account) says: I have only a very simple wireless network, a modem, a wireless router, internet that works with my Macbook and other devices, and an msi GT70 that refuses to connect to the internet. He also tried reinstalling the drivers and it didn't help. – slhck Nov 2 '12 at 17:19

You must log in to answer this question.

protected by Community Feb 27 '13 at 5:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?