Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had Xcode for a while (since Snow Leopard), and I installed Homebrew relatively recently (I currently have version 0.9.3). After an update to Xcode that recommended running an uninstall-developer-folder script, brew doctor fails with

Error: No such file or directory - /Developer

I've tried changing the path to the Xcode directory with sudo xcode-select -switch /Applications/Xcode.app, followed by brew update, but it doesn't seem to have changed anything. I've also tried to recreate /Developer and symlink everything it needs there, but I got stuck at

Error: No such file or directory - /Developer/SDKs/MacOSX10.6.sdk

My copy of the Snow Leopard SDK was removed along with /Developer and I can't find and installer for it that supports Mountain Lion.

My friend installed Homebrew at around the same time as I did (he currently has version 0.9.2). He installed Xcode much more recently, and so never had a /Developer directory. He hasn't had any problems with Homebrew; brew doctor comes up clean for him.

Both machines run Mountain Lion and have the latest version of Xcode and Xcode's command-line tools. Why does my copy of Homebrew require /Developer and the Snow Leopard SDK, and how do I make it work without them?

share|improve this question
    
Did you use xcode-select to point to the correct installation path? –  iltempo Nov 9 '12 at 2:10
    
I did, just now (and updated the question). brew doctor still complains for lack of /Developer. –  Blacklight Shining Nov 9 '12 at 15:45
    
Can you post the whole error message pls? –  iltempo Nov 9 '12 at 18:30
    
@iltempo Updated the question. –  Blacklight Shining Nov 9 '12 at 18:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.