Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Firefox 16.0.2 (the latest version) was working ok when I installed it, but today the whole system slowed down and only worked intermittently and screens kept losing focus before I could type in passwords, whenever Firefox was running.

I uninstalled Firefox and all plugins & settings and just ran IE for a while and everything runs smoothly. So I downloaded Waterfox (a 64 bit build from the Firefox code) and installed that. It runs perfectly now too.

I don't know what was wrong with Firefox, but I didn't have as many addons in it as I had before in Windows 7. Windows 8 was a clean (reformatted HD) installation, so there's no rubbish from the old system there.

share|improve this question
    
This sounds like a Firefox bug. I would open a bug report to Mozilla –  Ramhound Nov 1 '12 at 11:22
1  
Sounds more like an addon bug. I'm on beta update channel, currently on FF17 and no problems AT ALL. Try running with all addons disabled, reinstall flash. –  Bojan Kogoj Nov 1 '12 at 12:12
    
I think it is a problem with the Flash plug-in for Mozilla –  pratnala Nov 10 '12 at 11:20

2 Answers 2

Make sure you have not got a firewall blocking firefox or certain plugins. Try running without plugins to check if it is a plugin problem. Update all plugins. It could be a problem with flash as well which sometimes causes excess memory usage. For this disable hardware accelration in flash settings. I guess one of the above solutions must solve the problem.

share|improve this answer

I know in windows 7 Flash would really slow everything down. I went into settings and disabled hardware acceleration and it stopped.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.