Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a setup at my desk where I connect my computer to a an RJ45 switch that switches between two networks.

One network is the corporate network, which is maintained by my company's IT, and the other is my own private network where I do testing (the two networks have to be separated). The corporate network hosts the exchange server where I get e-mail.

When I switch from the private network to the corporate network, I expect Outlook to re-connect to the exchange server. However, I have found that sometimes when I come back, Outlook take an extremely long time to re-connect. Send/Receive will give me back the error 'The server is not available' (0x8004011D). It will sit there for 10 minutes to a few hours before it finally re-connects. The only other option is to reboot my computer, which is a huge pain for me since I run multiple VMs on it.

This usually happens when I'm connected to the private network for a significant amount of time, so I'm thinking it's because Outlook has cached the network status.

Is there a way to force Outlook to do a 'hard' re-connect to the exchange server?

I'm using Windows XP SP 3 with Outlook 2007.

share|improve this question
    
Does this also happen with other programs? How long do you wait between unplugging the network cable and replugging it into the other network? Does the problem persist if you wait a minute? If it does, could you try `ipconfig /flushdns' before retrying (in case it caches that mailserver.corp.foo is not valid). –  Hennes Nov 1 '12 at 15:32
    
It only seems to happen with Outlook - though it is the only application I use that connects to the corporate intranet. I can still access the internet and corporate intranet web sites when in this state. I've also tried ipconfig /flushdns and releasing/renewing the IP, all with no results. If I wait it always comes back - though it sometimes takes several hours. –  stan503 Nov 2 '12 at 13:22
    
Happens to me all the time as well. I use a VPN and if it drops sync and outlook can't connect it won't ever connect again until I quite outlook and restart. Really quite a pain in the ass, but this is a Microsoft product I guess. –  Bill Leeper Apr 23 '13 at 14:58
add comment

2 Answers

I have also had the same problem. It seems like the it could be happening when the mail server is set up with a domain name entry that has different values when inside the VPN vs on the Internet.

Easier set-up for the outlook admin, but you have to wait until the cached DNS for the mail server is flushed from your system.

I turned off caching exchange data and restarting outlook. Not always 100% success but seems to work a little better than waiting it out.

share|improve this answer
add comment

I have the same problem. I've found this: http://office-watch.com/t/n.aspx?a=1562 I haven't tried yet because Outlook just connected. It basically say:

In Outlook 2010 go to the Send/Receive tab and click on ‘Work Offline’, wait until the status bar changes from ‘Trying to connect’ to ‘Working offline’. Then click ‘Work Offline’ a second time, Outlook should then try to connect and, hopefully, succeed after a few seconds.

Edit: I tried this a few days ago and it worked like a charm.

share|improve this answer
    
Welcome to SuperUser, On this site we prefer concrete answers over guessing, when you do try this, please edit your question to reflect the results. –  David Mar 6 at 17:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.