Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been using Wamp with Windows 7 and when I recently upgraded to Windows 8 I have been unable to connect to the localhost. Uninstalling and reinstalling does not work. I also tried to install XAMPP to see if I can use the localhost on there but no. What is it about Windows 8 that is preventing me from doing this?

share|improve this question

3 Answers 3

Yes there is a beta version of Xampp(1.8.1)thats available for download.Here is the Link http://www.apachefriends.org/en/xampp-windows.html. Check if it works or not..

share|improve this answer

The problem come because Windows 8 integrated Microsoft IIS, and both WAMP and IIS use port 80. Find below how to fix it (the solution come from http://wpfirstaid.com/2012/11/wamp-server-microsoft-iis-windows-8-pro/ , so check the url for complete explaination):

Click on the WAMP Server system tray icon and follow this path to the first file to be edited: Apache -> httpd.conf Search for “Listen 80″ and change this to “Listen 8080″ (You can use most any number; 8080 is a common alternative in this case.) Locate the file wampmanager.tpl (generally found in the default folder: C:\wamp) and open it with your text editor. Search for any instance of the parameter “http://localhost/” and replace it with “http://localhost:8080/” (or the same number you used above.)

Now, Right-click the WAMP Server icon in the system tray and click Refresh and you should be able to work with both localhost environments: "http://localhost:8080/" with the WAMP Server; and, "http://localhost.com/" with the Microsoft-IIS services.

share|improve this answer
1  
Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  slhck Nov 10 '12 at 7:51

I dont think that windows 8 has anything to do with it, can you check your firewall , if its causing this problem. because in earlier windows versions. many people with firewalls have this problem. If the problem still persists then maybe i will install wamp and try it on my own windows 8.

share|improve this answer

protected by Community Sep 6 '13 at 12:21

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.