Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Windows 8, and I am unable to access the Store.

I receive the error:

We weren't able to connect to the Store. This might have happened because of a server problem or the network connection timed out. Please wait a few minutes and try again.

enter image description here

If I completely disable IPv6 on this computer, then I am able to access the Store normally.

enter image description here

How do I recover from this error?

There are no network proxies in use (it's at home!). "Use a proxy server" is not checked in the Internet settings. Other network connections work fine. I can browse the Internet from this PC with no issues and have no trouble accessing IPv6 web sites such as Google and Facebook. And the system time is in sync with "time.windows.com".


After a lengthy session with Sysinternals TCPView, I am observing the following behavior when opening Windows Store:

  • When I first open it, the system opens an HTTPS connection to 157.55.145.242 port 443. This connection transfers some data and gets closed almost immediately. This appears to be a Microsoft IP address.
  • Then, two connections are opened: an HTTPS connection to 23.12.49.138 port 443 and an HTTP connection to 2400:cb00:2048:1::adf5:3daf port 80. Neither of these two connections transfer more than a token amount of data, and remain open so long as the Store timeout screen (seen above) is up. I expected the Akamai IP address, since Microsoft is well known to use Akamai CDN, but I wasn't expecting to see a CloudFlare address! Both connections close as soon as I hit Alt+F4 to close Store.

Oh, and for those of you who didn't read it the first time, yes, the Internet works on this computer, on both IPv4 and IPv6. This occurs immediately after installation, before any anti-virus software has been configured. And Store is listed as an Allowed app in Windows Firewall, on both private and public networks.

This appears to be IPv6-related, since when I connect via IPv4 only, I can access the Store with no trouble.

share|improve this question

4 Answers 4

Try if your store is working after EACH of the fixes below, until it's working

Make sure internet is working (duh)

Check if you can connect to websites. If you can't, try the following:

Press win + R and type inetcpl.cpl.
In the window that appears, click on LAN settings.
Check "Use Proxy Server for your LAN" is unchecked like this:

Proxy settings

Check your date and time

Again, win + R and then type RunDll32.exe shell32.dll,Control_RunDLL timedate.cpl

Internet time -> Change settings -> Update now

Update now position

Windows Services

win + R -> msconfig

Click on Diagnostic Start Up then reboot.

Use your Local Account or another Account

Try registering for a new one if you have just one.

Last resort: refresh

win + C -> Change PC settings -> General -> Refresh your PC

Refresh windows 8

Source

share|improve this answer
    
I'm sure this will help somebody, but after spending nearly an hour going through this, I'm afraid I still have exactly the same problem, word for word. –  Michael Hampton Nov 1 '12 at 18:37
1  
The only other thing I can think of, is that you have a router or software/hardware firewall that blocks the ports needed for windows store. Is that your case? Are you otherwise able to access websites? –  Razor Nov 1 '12 at 18:41
    
How do you think I managed to post my question and screenshot? Indeed, all the other widgets on the Start menu (such as Weather) have no trouble accessing the Internet, and there's a '15' on the Store tile... –  Michael Hampton Nov 1 '12 at 18:42
1  
Again, do you have a router or software/hardware firewall that might be blocking ports? –  Razor Nov 1 '12 at 18:45
    
Of course I'm not blocking my own outgoing traffic. –  Michael Hampton Nov 1 '12 at 18:49
up vote 3 down vote accepted

This was eventually traced to an IPv6 routing issue with CloudFlare's network, and was affecting many other CloudFlare IPv6-enabled services as well. CloudFlare or its upstream providers have since resolved the issue.

enter image description here

(Though as of now they've screwed it up again...)

share|improve this answer

I have AVG and did the upgrade at work and at home to Windows 8 pro and on both machines I was unable to access the app store. After reading about the IP addresses and ports above I immediately thought "maybe my firewall is blocking these connections". So, I opened up AVG and turned off the firewall and BOOM I was able to connect to the app store. I then clicked on the "Regenerate Firewall Settings" within AVG and tried to connect to the app store and no dice. So, I disabled the AVG firewall for now and activated the windows firewall until I find a fix for AVG.

share|improve this answer

I tried all the suggested methods without any success. I was constantly coming up against "We weren't able to connect to the Store. This might have happened because of a server problem or the network connection timed out. Please wait a few minutes and try again."

This, despite having a working connection, all the relevant updates, and also caring out all and I mean all (including restoring to factory settings)

in the end what solved the problem for me was doing a full reset on my router. i then carried out a diagnostic on the router and connection, and set up the router again with ISP settings.

I then re-connected to the internet again and viola..... windows store was in full working order again.

I hope this information may help others as i was highly frustrated by the whole experience.

currently downloading 8.1 so here's hoping that the update will the bigger and better.

share|improve this answer
    
How did you configure IPv6 on your router? –  Michael Hampton Oct 17 '13 at 20:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.