Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There has always been a "Language for non-Unicode programs" settings in the "Region and Language" settings in XP, Vista and 7.

I installed Windows 8 (had some unrelated problems, so I had to revert to Windows 7 though), and I tried installing a piece of software that was not made with Unicode, but Shift-JIS (Japanese). The installer obviously shows incorrect glyphs, and the installer is unusable.

So I tried changing the "Language for non-Unicode programs" setting, but I noticed that the entire language applet was rebuilt from scratch.

As I reverted to Windows 7, I can't tinker with it until I solve the other problems and can get to install 8 again. But in the meantime, does anybody know where can I change this setting?

share|improve this question
add comment

1 Answer

up vote 6 down vote accepted

Windows 7's Region and Language has been split up in Windows 8 to separate Region and Language Control Panel applets.

  1. Go to Control Panel (the desktop version)

  2. Clock, Language, and Region

  3. Region
    2

  4. Click on the Administrative tab on the top

  5. Under Language for non-Unicode programs, select the button Change system locale, then select Japanese or whichever Asian display language you would like

  6. Restart your computer

The Japanese characters should display fine now.


Windows 7 Region and Language Applet
1

Windows 8 Language Applet
3

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.