Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I was installing winexe 1.00, after [winexe-1.00/source4/]./configure I got the following message:

checking for python2.6... /usr/local/bin/python2.6
checking for python2.6-config... /usr/local/bin/python2.6-config
checking working python module support... no
configure: error: Python not found. Please install Python 2.x and its development headers/libraries.

But I installed both Python 2.6 and 2.7. I couldn't find what's the problem.

share|improve this question

migrated from stackoverflow.com Nov 1 '12 at 18:16

This question came from our site for professional and enthusiast programmers.

    
The error message specifically mentions headers. Did you also install python2.6-dev (assuming Debian / Ubuntu)? –  tripleee Nov 1 '12 at 15:43
    
Thanks, when use this to install Python2.6-dev, it tells : E: Unable to locate package python2.6-dev E: Couldn't find any package by regex 'python2.6-dev –  Charlie Zeng Nov 1 '12 at 17:26
    
Tag this question with your operating system name. –  Shiplu Nov 1 '12 at 17:35
    
It's there. packages.ubuntu.com/search?keywords=python2.6-dev –  tripleee Nov 2 '12 at 5:02
    
Thanks. It's solved now. –  Charlie Zeng Nov 5 '12 at 16:00
add comment

1 Answer

just install python via yum or apt:

apt-get install python-all-dev
share|improve this answer
1  
More detail would improve this. –  Dave M Oct 3 '13 at 12:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.