Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently saw the Microsoft blog entry describing the new features of RDP 8.0 and how to enable this new functionality.

http://support.microsoft.com/kb/2592687

I successfully upgraded a Win7 Ultimate (x64) and Win7 Enterprise (x64) machine following these instructions. I also have a Win7 Home Premium (x64) machine which obviously does not have the "Local Group Policy Editor" and the instructions only reference policies and not registry entries.

I eventually took snapshots of my registry on my Win7 Ultimate machine before and after changing the policies to determine the registries keys changed. Here are the keys I noted and tried incorporating into my Win7 Home Premium machine which did not work.


[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\TerminalServices]

"fServerEnableRDP8"=dword:00000001

"SelectTransport"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Policies\Microsoft\Windows NT\Terminal Services]

"fServerEnableRDP8"=dword:00000001

"SelectTransport"=dword:00000000


Any thoughts, ideas, or instructions for next steps would be appreciated. (UDP support and a resizable connection bar alone make this a worthwhile update for me!)

Sincerely,

Mike

share|improve this question
add comment

2 Answers

I got to thinking about the order of the prerequisite hot-fix and the subsequent update in terms on my Win7 Home Premium machine. I went back, uninstalled both patches, reinstalled both patches in the correct order and everything is working as intended now. I may have also had remote desktop running when I applied the patches, possibly preventing an update even though it does a reboot for system files.

More info from a different thread I started over at technet:

http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/2b8021df-7944-401d-ba21-606308bb9219

share|improve this answer
add comment

I went on to the Microsoft site as I also had all the correct fixes and protocols and still couldn't get remote access to work. One of the responses said that a lot of people were using Team Viewer. I have just installed it on both of our laptops and it worked immediately. Awesome software.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.