Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 5 user peer to peer network. 2-XP machines, 3- Windows 7 machines and a Windows 7 machine acting as the file server. I have NO issues with the Windows 7 machines staying connected via the mapped drives to the "server". However, once a day the 2 XP machines will not connect to the Windows 7 machine "server" via the mapped drives. I must restart the "server" in order to see the server and access the files via the mapped drives or Explorer. I have tried the persistent : yes command in NET USE, on the XP machines and also setting a static IP address on the "server". I've turned the firewall off on the "server:, no difference so I turned the firewall back on. No interruption occurs with the internet when this happens, just can't see the server. Again, the Windows 7 users are unaffected. I have gone into the advanced network settings on the "server" and added read/write permissions for Everyone as well as the users of the XP machines. I have double checked that we are all on the same WORKGROUP. I'm at a loss. It seems to happen around mid-day and I've not been able to find any activity that is happening at this time (Like someone plugging in a thumbdrive). Any suggestions would be greatly appreciated as my client is running old XP software he no longer has the disks for and needs for his engineering firm.

share|improve this question
    
Did you map the drive using an IP address or a hostname? Try remapping the drive using IP's instead of names if that is the case. Wouldn't hurt to also add entries in your HOSTS file as well - Name resolution via NetBIOS between XP and 7 is a little shaky. –  Scandalist Nov 2 '12 at 4:08
    
@ Scandalist I used the hostname, I'll try the ip addresses. Do you know how to edit the host file? –  Kathryn Codo Nov 2 '12 at 19:27
    
%systemroot%\system32\drivers\etc\HOSTS Open that file with notepad and manually map hostnames to IP addresses for your network. It will give you example configurations. –  Scandalist Nov 3 '12 at 4:17
    
@Scandalist Thanks I'll try that tomorrow when I go to the site and let you know. Right now it's loosing conncetion about 2 times per day –  Kathryn Codo Nov 6 '12 at 0:19
    
I edited the hosts files on both XP machines last week. About a day went by and no communication loss. Now the XP machines are loosing communication again (about twice per day) I'm going to replace the NIC on the server, but I'm open to suggestions. Kathryn –  Kathryn Codo Nov 15 '12 at 17:32
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.