Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not sure how it happened, but on startup my VS 2012 copy reads

Licensed To: "----------------Hewlet-Packard (blah)..."

I have no idea how that got there. We installed through our MSDN subscription. Anyone know of a simple way to replace this with either my name or my company's?

This makes me sad inside.

share|improve this question

migrated from stackoverflow.com Nov 2 '12 at 9:54

This question came from our site for professional and enthusiast programmers.

1  
This is a software user question, not a programming question (even though it's VS-2012 related). It doesn't belong here. Voting to close (and you should probably delete), but you can find the information it reads in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion, as RegisteredOrganization and RegisteredOwner. Windows Installer reads the information from there, and usually presents it to you to change during the install process. Note that the information in this key is global, meaning changes can affect other things on your system. –  Ken White Nov 1 '12 at 22:06
add comment

2 Answers

up vote 18 down vote accepted

For Windows 7 I found the following instructions on this site:

  1. Open Registry Editor (Start->Run->type “regedit”->press enter)

  2. Find the following key: HKCU\Software\Microsoft\VisualStudio\11.0_Config\Registration\UserName

  3. Change it’s value to the desired name

  4. Navigate to the following folder: C:\Users\{YOUR_USER}\AppData\Roaming\Microsoft\VisualStudio\11.0 (replace the placeholder with your own username)

  5. Delete the file vs000223.dat – this is actually a JPG file containing the splash screen, you can change it’s name to see it for yourself

  6. Start Visual Studio, and it magically recreates the file with the modified name in it!

share|improve this answer
13  
The path to vs000223.dat in my case was C:\ProgramData\Microsoft\VisualStudio\11.0\ –  wizlb Nov 21 '12 at 4:57
    
To expand a bit on wizlb's comment, I'm running Windows 7 SP1 on a 64-bit machine and mine was in that location as well. Regedit changes are only necessary to change the name; search for RegisteredOrganization key to change the company. –  James Skemp Apr 7 '13 at 13:46
    
For those using VS Express - substitute VisualStudio to WDExpress or VWDExpress depending on which edition you are using. Process regedit then AppData and ProgramData still applies. –  laika May 12 '13 at 11:26
add comment

Actually you have to delete the vs000223.dat from both ProgramData and AppData. The one in AppData acts as the main Splash Screen while the one in ProgramData acts as a backup. If the one in AppData does not exist, Visual Studio 'copies' the one from ProgramData. If both don't exist, Visual Studio writes a new vs000223.dat into AppData but not into ProgramData.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.