Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After I installed Bitdefender Total Security 2013, I can't print. I found that I can print only when I turn off firewall (from Bitdefender) How can I print with firewall?

I think I should give permission in Settings, but I have no idea.

Network type is Home/Office, Stealth mode is remote, Generic is No.

It is HP Laserjet connected to the wall by LAN cable. I add the printer in Windows 7 by "Add a network, wireless or Bluetooth printer", select "The printer that I want isn't listed", select "Add a printer using TCP/IP address or hostname", and then enter hostname or IP address.

share|improve this question
    
What kind of printer? How is it attached? –  Ƭᴇcʜιᴇ007 Nov 2 '12 at 15:17
    
It is HP Laserjet connected to the wall by yellow LAN cable. I add the printer in Windows 7 by "Add a network, wireless or Bluetooth printer", select "The printer that I want isn't listed", select "Add a printer using TCP/IP address or hostname", and then enter hostname or IP address. –  user67275 Nov 2 '12 at 15:26
add comment

1 Answer 1

up vote 1 down vote accepted

Ensure you've set your LAN and/or that device to be a 'trusted zone' in BitDefender:

A trusted zone is a device that you fully trust. All traffic between your computer and the trusted device is allowed. To share resources with specific devices, such as computers or printers, add them as trusted zones.

To add a trusted zone:

  1. Open the Bitdefender window.
  2. Click the Settings button on the upper toolbar..
  3. In the Settings Overview window, select Firewall.
  4. In the Firewall Settings window, select the Settings tab.
  5. Under Firewall Rules, click Adapter Rules.
  6. To add a zone, click the corresponding button. A new window displaying the IP addresses of the devices connected to the network will appear.
  7. Select the IP address of the computer or the printer you want to add, or type an address or address range in the provided text box.
  8. Go to Permission and select Allow.

Source: The Manual for BitDefender 2013, Section 30.5: "I cannot access a device on my network"

share|improve this answer
    
Thank you for your response. Actually, my network printers don't appear in the list at step 7. Thus I have to enter all IP addresses of my printers. –  user67275 Nov 5 '12 at 0:00
    
I also found that using Windows firewall and turn of Bitdefender firewall can be another option. –  user67275 Nov 5 '12 at 0:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.