Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Google Chrome set to be the default browser, but all hyperlinks are still opened in Internet Explorer 10.

Chrome is the default application for .html files, which is odd because I never selected a default program for .html files.

What should I do to open all hyperlinks in Chrome by default?

share|improve this question
add comment

3 Answers 3

up vote 7 down vote accepted

There's no difference between being the default for the desktop and being the default for Metro/Modern UI. There's only one place to set this, and it should cover both. You can however set only the extension .html to default to Chrome, and still have hyperlinks go to Internet Explorer.

It would not surprise me to find an entry in the registry that contradicts the default desktop program vs default metro, however there's no setting or place in the control panel to change this. Take a look at this question. The answer which received the bounty seems to indicate there is a registry entry somewhere that may or may not indicate an MUI app being set as default, however it may not have any effect on the behavior of hyperlinks.


Open up start and search for Default Programs:

enter image description here

Now choose Set your default programs: enter image description here

Take a look at Chrome and see what it has set. Mine only had 3 out of 18: enter image description here

There's a difference between .html extensions and HTTP protocol! Setting Chrome as the default for .html will cause .html files from the desktop or explorer to open in Chrome. We want to make sure that Chrome is the default for HTTP protocol. enter image description here

Make sure HTTP, URL:HyperText Transfer Protocol and HTTP, URL:HyperText Transfer Protocol with Privacy are both set.

share|improve this answer
add comment

That could be happening because you only set the default browser for desktop or metro, not both - make sure that it's been set as default in each.
From google chrome help:

  1. Click the Chrome menu on the browser toolbar.
  2. Select Settings.
  3. In the "Default browser" section, click Make Google Chrome my default browser.

Windows 8 users: To launch Chrome as a Windows 8 app from your Start Screen, follow the steps above and set Chrome as your default browser. Learn more about Windows 8 apps

EDIT

Some programs always force Internet Explorer to open links, there's nothing you can do about that.
If the steps above don't help, can you check if other programs open link with chrome (e.g. the default "mail" app)?

share|improve this answer
    
how to set default browser for both metro and desktop.your steps say how to set chrome as default browser,which I have already done.I am using the same old desktop version of chrome –  vishesh Nov 2 '12 at 15:39
    
@vishesh you need to do it twice: once inside chrome for desktop, once with chrome for metro. I actually just tried to reinstall it and this was done automatically: the steps above were needed only for old versions. –  Razor Nov 2 '12 at 15:50
    
so this means we need the metro version of chrome,just for opening links by default in chrome.I can't really upgrade to metro chrome due to my slow connection :( –  vishesh Nov 2 '12 at 15:52
    
@vishesh you should already have chrome for metro, as it gets installed along with the desktop version. Try pressing "WIN" and then typing "chrome": you should see it listed. –  Razor Nov 2 '12 at 15:58
    
"once inside chrome for desktop, once with chrome for metro" - Even for old versions, this sounds like a Chrome bug. Users should be required to do this only once in either version. –  Karan Nov 2 '12 at 17:25
show 1 more comment

1.Click the Chrome menu on the browser toolbar. 2.Select Settings. 3.In the Default browser section, click Make Google Chrome my default browser.

I think this can help

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.