Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am seeing very strange behavior with images not appearing on a site. Other people have reported being able to see them, but it seems that I am the only one that can't.

The site is at http://FiveYearsAbroad.com. The only image that I can see, is the small image on the right; all others on the main page will not show and just appear as broken links. The small image on the right is being hosted from a different server than the site content images.

Here is what I've tried so far.

I've copied the image link directly from the proprieties and have tried to navigate there manually. What I get is "Unable to complete secure transaction". The image link for this test is: https://fbcdn-sphotos-g-a.akamaihd.net/hphotos-ak-snc6/229840_4308044972063_1690267747_n.jpg.

The images are hosted over a secure connection so if there was a problem with the SSL, I should get some sort of an error, but never do.

I am not using a firewall or virus software. This behavior is happening in firefox, Opera as well as in IE 8. I have gone to other secure sites and do not see this issue with images hosted over a secure connection.

Can someone offer up some possible solutions for a fix?

share|improve this question
    
Possibly related: superuser.com/q/179489/67218 –  todofixthis Nov 3 '12 at 1:00
    
If others can see them and you do not; (very odd), clear cache, force refresh, try other browser? –  Random O'Reilly Nov 22 '13 at 0:52
    
sorry - i see you said you tried ff, opera and IE. If others can see the images ( i took a look at the site; but it is unclear to me what I should see as opposed to what I do see), then it must be your machine/phone/tablet/incoming line. –  Random O'Reilly Nov 22 '13 at 0:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.