Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 monitors and in Windows 7 I used to just mouse-flick maximized windows from one monitor to the other.

With Windows 8 however (charms disabled), my mouse hangs in the corners while doing this. This is because as described at the end of this article, an "invisible barrier" of 6 pixels has now been added:

Sticky Corners in Win8

Thus I'm unable to have a smooth experience for window movement across monitors as I did back in Windows 7. (Both my monitors are aligned in the settings to the top, so that isn't the problem).

How do I disable the mouse from stopping in the corners when going from one monitor to the other?

Edit: So it seems this is not possible without programming effort. I am currently writing a small tool to circumvent this nuisance. It's already working, I'm just touching up on the visuals :)

Edit2: https://mouseunsticky.codeplex.com/

share|improve this question
3  
Not a solution to your exact problem, but an alternative way of doing this would be: Windows key + Shift + Left/Right arrow to quickly move apps from one monitor to the other. –  Mufasa Nov 2 '12 at 18:03
    
And here I thought it was totally useless because the corners weren't big enough... –  Shinrai Nov 2 '12 at 19:16
4  
Codeplex link is broken. –  Drew Noakes Dec 19 '12 at 14:46
add comment

7 Answers

You can get around this with a simple registry change.

In registry, search: MouseCornerClipLength
Set the value to 0 (from 6).
Repeat (there is more than one key with this name, I'm not sure which one(s) are necessary).
Restart.

This stops your mouse catching and is perfect, you can still use the charms bar without issue on the outside edge of your monitors as easily as before (exactly as I wanted).

I created a thread a while ago about this here: http://answers.microsoft.com/en-us/windows/forum/windows_cp-desktop/how-to-disable-hot-corners-on-dual-screen/69b45244-ffc7-4ac7-8473-d69c3799245b?msgId=8d4d2be9-7878-4a76-8429-0087ae27750b&page=2

share|improve this answer
2  
THANK YOU! You are a saviour. I had this annoying issue on multiple monitors with different resolutions, and almost banged my head. Thanks again! –  Prasanth Jul 2 '13 at 13:38
2  
A quick search indicates that it's actually a per-user setting, and you can set it for the current user at HKEY_CURRENT_USER\Control Panel\Desktop\MouseCornerClipLength The other results were in similar locations in HKEY_USERS, which would be the corresponding setting for other users. –  Bob Jul 8 '13 at 16:44
    
Thank you, thank you. Lovely, smooth, top edge is back. Amazing how much something so simple can disrupt your work. –  Xonatron Nov 1 '13 at 20:02
add comment

Tested and working

Open Regedit.

And go toHKEY_CURRENT_USER/Control Pannel/Desktop search for a key named MouseCornerClipLength and change the value from 6 to 0.

Ok and restart the machine

share|improve this answer
    
Just a note that this one sets it for the current user. –  Xonatron Nov 1 '13 at 20:03
add comment

You can download a third-party program called Start 8. With it you can disable the sticky corners and you can also, if you want, get back the old Windows 7 style start menu.

It costs $5 but it has a free month trial.

share|improve this answer
    
That is incorrect. It let's you disable the hot corner charms, but not the sticky pixels. –  Arista2 Nov 3 '12 at 1:59
add comment

PowerShell:

Set-ItemProperty -Path "HKCU:\Control Panel\Desktop" -Name MouseCornerClipLength -Type String -Value 0
share|improve this answer
add comment

There is a program called Skip Metro Suite. You can use it for diasbling all hot corners of Windows 8. You can download from here: http://winaero.com/download.php?view.33

enter image description here

share|improve this answer
    
This finally worked for me. Thanks! –  phw Mar 13 '13 at 8:14
add comment

Until someone comes out with a hack, this will continue to be a setting built into Windows 8. You'll unfortunately have to get used to watching those corners, and eventually this will become second nature.

share|improve this answer
add comment

They can't be disabled. I wish we could vote on features to be added/removed from W8!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.