Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm attempting to use the "fontpatcher" that comes with vim-powerline in order to add some glyphs to the ProggySquare font (.dfont version). This script appears to just use fontforge's internal libraries in order to get the job done. I've installed fontforge from homebrew on my Mac (running 10.7).

Unfortunately, the result is a .bdf file that contains CHARS 0; it doesn't actually contain any glyphs. If I open ProggySquare.dfont with the GUI version of fontforge then I can see all of the glyphs but they all have a faint red 'X' over them. No matter how I fiddle with the Encoding menu or with the "File > Generate Fonts..." menu, I cannot eliminate the red 'X'es or create an output font file that has any glyphs in it. Does anyone know precisely what those red 'X'es are indicating in this case, and (more importantly) how to remedy my situation?

As a workaround I was able to switch to the TTF version of the font, in which fontforge and fontpatcher are able to find glyphs. Unfortunately that also seems to have some other sort of bug and generates glyphs that are too tall (and maybe too wide too?). I'm not sure what's going on there, so bonus points if you can solve that too...

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.