Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Windows Vista, when browsing to a network folder containing executables, Windows Explorer seems to load all the files completely just to be able to show the executable icon (the resource monitor indicates loads of traffic during the loading of the directory)

On XP only a part of the file is loaded.

Is there a way to avoid the complete loading of these files?

Note that disabling my anti virus does not help.

Update: This only happens with for executable linked with /SWAPRUN:NET. Microsoft confirmed this as a bug in Vista, but they seem not very eager to fix this.

share|improve this question
    
> This only happens with for executable linked with /SWAPRUN:NET. Well that makes sense. That option specifies that the file is to be copied from the network store to the swapfile before being run locally. The problem of course is that it also causes the file to be copied when loading the resource section (eg icon) in addition to the code section. If Microsoft has confirmed it to be a bug (is there a KB article?) then hopefully they will release an update to fix it (or at least a hotfix you can download in the meantime). –  Synetech Feb 24 '12 at 3:08

4 Answers 4

Are you sure that Explorer is one to blame? I would assume that some other software is reading whole files (e.g. anti-virus) since Windows Explorer will only load resource part of exe.

share|improve this answer
    
I tried to disable my AV, but that does not help. I updated the question. –  user13001 Oct 2 '09 at 8:04
    
Which program are you using to know that whole file is loaded? –  Josip Medved Oct 2 '09 at 8:41
    
I just base that on the amount of network traffic that is generated during the load of the directory: both the windows Resource Monitor as NetMeter 1.1.3 (metal-machine.de/readerror) indicate large volumes of incoming network traffic. –  user13001 Oct 2 '09 at 8:58

Your explanation of the slow-down might be incorrect.

From Windows Vista Slow Network Issues:

Microsoft Windows Vista has auto-tuning enabled for TCP/IP which continually adjusts itself. It increases file transfer speed on the network but in some cases it may actually slow down everything which is accessing network. Auto-tuning also slows down network browsing of other machines on the network.

To disable auto-tuning:

Run command prompt as an Administrator. Type:
netsh interface tcp set globalautotuninglevel=disabled
and press enter.

You may also need to run this command:
netsh interface tcp set global rss=disabled

share|improve this answer
    
dear god, tell me that's not web-style RSS in Vista's TCP/IP stack... –  quack quixote Oct 2 '09 at 8:19
    
Looking at the resource monitor really show a lot of traffic (caused by 'System'), so I really think it is loading the complete files. I updated the question. –  user13001 Oct 2 '09 at 8:30
    
But did you try this solution? The article I quoted also shows how to undo the change if it doesn't help. –  harrymc Oct 2 '09 at 8:52
    
Eli, have you given thought to the possibility that XP handled the exact same amount of network traffic, just faster? –  harrymc Oct 2 '09 at 20:27
    
That cannot be it neither, I monitored the traffic on an XP system as well. I'm more thinking about a driver issue. I noticed that the resources (icons, version nrs, ...) in the executables are spread all over the file, and it seems that instead of seeking at the correct position, the whole executable is loaded. –  user13001 Oct 5 '09 at 7:26

Are you absolutely sure the machine is not infected with a virus (and attempting to infect the network files)?

Also, is it faster to access the folders the second time? If not, the icon caching may not be working, so it could be a problem with IconCache.db or perhaps with the cache limit is too small (google for "Max Cached Icons" for more info)

This could be caused by an faulty add-on that hooks into windows explorer, so you might try AutoRuns (from sysinternals) to see what non-Microsoft addons are being loaded and possibly disable them.

Also, are you sure it is just the exes that cause the problem? You may get speed problems if any of the files in the folder are associated with a program which is no longer there and windows explorer constantly attempts to open this non-existent program to find the icon. (For this to cause network traffic, presumably it the program must have been originally installed on the network).

ShellExView from Nirsoft or Process Monitor (from Sysinternals) might also help if that is the case.

share|improve this answer

Is there a way to avoid the complete loading of these files?

Yes, you have to change the following registry key:

[HKEY_CLASSES_ROOT\exefile\DefaultIcon]
@="%1"

Change %1 to a local file.

Regards Oliver

share|improve this answer
    
That helps considerably. If it would be possible to do this for exe's on a network disk that would be great. –  user13001 Mar 19 '10 at 12:08
    
The above registry entry changes the icon for all .exe files regardless of their location. –  Synetech Feb 24 '12 at 3:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.