Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm new to linux. For some work I need to install php but not necessarily apache as I'm using my own webserver. I'm using Ubuntu 8.10. But when I try to install php I get the following error.

root@ubuntu:/home/sam/WS/webserver#  apt-get install php5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
.E: Couldn't find package php5

same type of error if I try to install apache as well. I read on web that it's a repository related problem. When I try a 'apt-get update' I get 404 errors. I have pasted this output at http://pastebin.com/g74DNzxL.

Please tell me how do I install php on ubuntu 8.10.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Its a really old version of ubuntu and is no longer supported. You're better off upgrading to a new version of ubuntu (preferably the latest LTS). You won't get updates, things could break, you have outdated packages without the latest security and functionality patches. I SERIOUSLY RECOMMEND UPGRADING

Now that we're done with that...

Apparently you MIGHT be able to access older repos by changing your sources.lst to have the last update of the repos from EOLed repositories.(source). Rename your /etc/sources.lst to sources.lst.old, and paste the below into a new /etc/sources.lst file

## EOL upgrade sources.list
# Required
deb http://old-releases.ubuntu.com/ubuntu/ intrepid main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ intrepid-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ intrepid-security main restricted universe multiverse
# Optional
#deb http://old-releases.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse

apt-get update && apt-get install php5
and hope its still up. This is not a good idea, and not really tested

share|improve this answer
    
Thanks you for the source. it works! –  user601L Nov 3 '12 at 7:08

The reason this is not working is that the Ubuntu main repositories have removed the packages for Ubuntu 8.10, because it's:

  • Not a Long Term Support (LTS) release; and
  • It's extremely old (the "8" in the version number is for the year 2008, which now is about 4 years ago). In terms of the rate of evolution of the Linux desktop, using a 4 year old distribution is the equivalent of driving a car from 1935.

There is a mirror for ancient packages here with a working apt repository as well as ISO image downloads. You can point your /etc/apt/sources.list file to this location instead of the default repo.

However, I would very strongly recommend that you stop trying to use such an old distribution. If you need to use something old and stable that's supported for a long time, you have two options:

  • As a first option, use Ubuntu 12.04, released in April 2012. If this works for what you want to do, great.
  • As a second option, use Ubuntu 10.04, released in April 2010. If this works for what you want to do, that's fine.
  • As a final option, use Ubuntu 8.04, released in April 2008. This is actually older than Ubuntu 8.10, but it is officially supported on Ubuntu Server until April 2013.

See this Wiki page which describes the Ubuntu release lifecycle, where you have several standard releases (usually 3) which each become unsupported after a very short time (a year and a half), followed by a long-term support release which is maintained for security and bugfix updates for a very long time (4 years for desktops, and 7 years for servers).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.