Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Could someone provide some steps for me to check my internet connection on my Windows Home Server? It seems to have intermittent connectivity issues and I am unsure of how to diagnose the problem because it is a headless (no monitor, no keyboard) machine so the only way to get to the device is via remote desktop (which works fine).

When connected to the machine, it doesn't pull up any sites and some other sites it does pull up (i.e. and some it doesn't ( To make matters more complicated, it has worked intermittently in the past for reasons unknown.

Are there tools I can use to properly diagnose the reason for the connection failure? I can ping just fine, I have internet working on my other router-connected machines, so I'm not sure why this one would fail.

Any suggestions would be much appreciated and up-voted :)

** edit - thanks for suggestions guys, I'm going to try these tonight and will update my post.

** edit #2 - I hoping this is a more permanant fix, but I have both changed my port on the router as well as restarted the router at the same time. The internet (for the moment) appears to be working. I will be sure to try everything we have discussed should this problem persist.

Thanks, Kyle

share|improve this question

migrated from Oct 2 '09 at 9:08

This question came from our site for system and network administrators.

This is odd.

One thing to make sure is that you aren't cacheing those pages. Try checking out a site you never go,, etc, etc. If these don't load and google does google might just be cached.

Next, check to see if it is DNS. Try pinging If that works try pinging If that doesn't work, then I'd use openDNS's DNS servers. Open DNS . Next, I would check the network adapter to see what it is using as a DNS server and make sure this is correct.

share|improve this answer

Well not being able to connect to the internet there could be many issues. Since you are able to remote desktop in I would check and make sure that your DNS settings are correct. Open up a command line and run nslookup. Enter a few domains such as and in the tool and make sure your getting addresses back. If your not try manually setting your DNS server to (Level 3's root DNS server) and see if that solves the issue.

If your still not able to connect (this assumes that remote desktop is working on the LAN only) you might want to look into your routes. Open up a command line and enter 'route print'. The last line should look something like:

Default Gateway:

If you don't have a default gateway that is your problem. If you have the IP set statically then the problem is probably that you didn't define the default gateway when you gave it's address. If it gets it's IP from a DHCP server check and make sure that it is handing out an appropriate IP and make sure you can ping the gateway.

I ran out of time, but when I get back I'll see if I can offer a few more troubleshooting options.

share|improve this answer

Another possibility is that WHS is based on W2k3 so comes fairly locked down. IE is installed in restricted mode and is a pain to work with. Try ping suggestions and if you can ping out but can't get IE to work maybe try another browser?

share|improve this answer

I had the same problem and it turned out to be the DNS settings. I could ping other computers connected to the WHS computer but couldn't get the internet with either IE or Firefox like I could previously. I set the DNS settings to the Open DNS ip of and even though I had a DNS setting already set up in the router and it fixed this problem.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .