Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Could someone provide some steps for me to check my internet connection on my Windows Home Server? It seems to have intermittent connectivity issues and I am unsure of how to diagnose the problem because it is a headless (no monitor, no keyboard) machine so the only way to get to the device is via remote desktop (which works fine).

When connected to the machine, it doesn't pull up any microsoft.com sites and some other sites it does pull up (i.e. gmail.com) and some it doesn't (stackoverflow.com). To make matters more complicated, it has worked intermittently in the past for reasons unknown.

Are there tools I can use to properly diagnose the reason for the connection failure? I can ping 127.0.0.1 just fine, I have internet working on my other router-connected machines, so I'm not sure why this one would fail.

Any suggestions would be much appreciated and up-voted :)

** edit - thanks for suggestions guys, I'm going to try these tonight and will update my post.

** edit #2 - I hoping this is a more permanant fix, but I have both changed my port on the router as well as restarted the router at the same time. The internet (for the moment) appears to be working. I will be sure to try everything we have discussed should this problem persist.

Thanks, Kyle

share|improve this question
add comment

migrated from serverfault.com Oct 2 '09 at 9:08

This question came from our site for professional system and network administrators.

4 Answers

This is odd.

One thing to make sure is that you aren't cacheing those pages. Try checking out a site you never go to...nike.com, iwillteachyoutoberich.com, etc, etc. If these don't load and google does google might just be cached.

Next, check to see if it is DNS. Try pinging 74.125.45.100. If that works try pinging www.google.com. If that doesn't work, then I'd use openDNS's DNS servers. Open DNS . Next, I would check the network adapter to see what it is using as a DNS server and make sure this is correct.

share|improve this answer
add comment

Well not being able to connect to the internet there could be many issues. Since you are able to remote desktop in I would check and make sure that your DNS settings are correct. Open up a command line and run nslookup. Enter a few domains such as google.com and serverfault.com in the tool and make sure your getting addresses back. If your not try manually setting your DNS server to 4.2.2.1 (Level 3's root DNS server) and see if that solves the issue.

If your still not able to connect (this assumes that remote desktop is working on the LAN only) you might want to look into your routes. Open up a command line and enter 'route print'. The last line should look something like:

Default Gateway: 192.168.0.1

If you don't have a default gateway that is your problem. If you have the IP set statically then the problem is probably that you didn't define the default gateway when you gave it's address. If it gets it's IP from a DHCP server check and make sure that it is handing out an appropriate IP and make sure you can ping the gateway.

I ran out of time, but when I get back I'll see if I can offer a few more troubleshooting options.

share|improve this answer
add comment

Another possibility is that WHS is based on W2k3 so comes fairly locked down. IE is installed in restricted mode and is a pain to work with. Try ping suggestions and if you can ping out but can't get IE to work maybe try another browser?

share|improve this answer
add comment

I had the same problem and it turned out to be the DNS settings. I could ping other computers connected to the WHS computer but couldn't get the internet with either IE or Firefox like I could previously. I set the DNS settings to the Open DNS ip of 208.67.222.222 and 208.67.220.220 even though I had a DNS setting already set up in the router and it fixed this problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.