Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My problem is that after being idle for a while, the screen is locked and after this happened I get a black screen from which I can't get rid of. I mean after black screen comes, typing and moving mouse does not bring any new screen, and even alt+ctrl+F1 to F7 changes nothing. All I can do is to restart the system.

Can anybody help me with this?

share|improve this question

migrated from stackoverflow.com Oct 2 '09 at 9:32

This question came from our site for professional and enthusiast programmers.

    
So, does it respond to Ctrl-Alt-F1, or does that do nothing either? If it does respond, maybe you can do some top or ps -ef magic on the command line to see what's going on? –  Arjan Oct 2 '09 at 23:55
add comment

2 Answers 2

This happens if your system goes to SuspendToRam automatically and your graphics card has problems with this mode.

Either turn of SuspendToRam or configure it correctly (depends on your graphics card).

share|improve this answer
    
I had this happen to me and thought it was a random system freeze. It's quite possible this is why. I never purposefully suspend, but it's a new install and maybe I missed a setting somewhere. +1 thx! –  quack quixote Oct 2 '09 at 9:55
add comment

I was having a similar problem recently and came to discover that an auto-refreshing AJAX page I was keeping loaded in a Firefox tab was causing Firefox to just start eating memory (like, 2 gigs of RAM on my 4 gig machine). From my perspective, it seemed locked up; it actually took a couple of minutes for a Ctrl-Alt-F1 to finally display the text console (at that point I was able to see the memory issue). And this is on a pretty fast quad core desktop.

So, is it possible that you have some program running in the background that is eating up memory while you are away, and that the system is just being really unresponsive?

Another thought; if you can ssh to the box you could try killing the Xscreensaver process.

share|improve this answer
    
tried that when it happened to me, but no dice. system didn't even respond to pings (tho it was a pretty new install and i couldn't be sure there wasn't a firewall at fault for that). i expect a SuspendToRam issue would prevent network responses, though. –  quack quixote Oct 2 '09 at 21:31
    
0 vote down check Thanks Eric Asberry! You are right, changing my screen saver solved the problem. –  Navid Oct 2 '09 at 23:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.