Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to install any extension for visual studio ultimate 2012 on my new installation of Winodws 8 I get this exception :

System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002) at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo) at Microsoft.VisualStudio.Settings.ExternalSettingsManager.GetScopePaths(String applicationPath, String suffixOrName, String vsVersion, Boolean isLogged, Boolean isForIsolatedApplication) at Microsoft.VisualStudio.Settings.ExternalSettingsManager.CreateForApplication(String applicationPath) at VSIXInstaller.App.GetExtensionManager(SupportedVSSKU sku) at VSIXInstaller.App.GetExtensionManagerForApplicableSKU(SupportedVSSKU supportedSKU, IInstallableExtension installableExtension, List`1 applicableSKUs) at VSIXInstaller.App.InitializeInstall() at System.Threading.Tasks.Task.InnerInvoke() at System.Threading.Tasks.Task.Execute()

I tryed to repair VS, did not work, and also try to uninstall/install and got the same problem. Anybody as an idea?

share|improve this question
1  
did you try running as admin? Where is VS installed? Are you redirecting your documents folder to a network share? –  Louis Nov 3 '12 at 17:06
    
Yes I try to run as admin and it does not change anything. I got it working on my PC at work but not at home. It's all on c drive. –  VinnyG Nov 3 '12 at 17:21
    
not quite sure if it's an answer but if I add full control to security tab direct on my c: the install works... –  VinnyG Nov 7 '12 at 2:57

1 Answer 1

I was stumped by this until I realized that I had somehow deleted my My Documents directory. Recreating C:\Users\<username>\Documents allowed it to install.

Others have reported the same bug when My Documents has been remapped to a different location. The workaround is to map it back to the standard location, install the vsix, and reestore your mapping.

If all else fails, you can manually unpack the extension:

  • In Visual Studio, go to Tools > Extensions and Updates, and install a working extension from the online repository (I used "Microsoft Visual Studio 2012 Feedback Tool"). For some reason, this is needed to get new extensions you manually unpack to show up in VS.
  • Close Visual Studio.
  • Unpack the .vsix file as a subdirectory of the Visual Studio extensions directory C:\Users\<username>\AppData\Local\Microsoft\VisualStudio\11\Extensions\, alongside the extension you installed (I used 7-zip).
  • Re-open Visual Studio. Under Extensions and Updates, the new extension showed up but was marked disabled. Enable it and restart VS.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.