Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have moved my Downloads folder to a different partition in Windows 8 and changed its icon.

Every time File Explorer restarts, the icon reverts back to the default. I deleted the desktop.ini file and tried many times but still the issue persists.

How do I fix this?

This didn't used to happen in Windows 7.

share|improve this question
Have you tried to remove explorer cache? – Searush Nov 3 '12 at 17:41
1)Remove cache 2)restart explorer (or better, windows). Isn't it working?? – Searush Nov 3 '12 at 17:49
up vote 2 down vote accepted

For folder icon customization to work,

  • the folder should contain desktop.ini which points to the icon that can be accessed.
    This is a copy of desktop.ini for Downloads folder:

  • and the folder itself should have Read-Only attribute set.

You cannot set Read-Only attribute from Windows interface, therefore you have use either attrib command-line utility or other tools as Far Manager or Total Commander.

To set Read-Only attribute run:

attrib +R Downloads

Then you can check if it's set:

attrib Downloads
     R       C:\Users\username\Downloads
share|improve this answer

I gues it has something to do with the registry values.Classic case was Vista with the same kind of problem :-Automatic Folder Type Discovery

Automatic Folder Type Discovery is when Windows will automatically change the folder template of a folder to match the file type of the last file added or saved in the folder. For example, if your folder contains music files and you add a picture file, then Windows may change the folder template and view to the "Picture" template to match the new picture file

You can try disabling Automatic Folder Type Discovery

Here is Link that shows certain Scenarios and you can also gp through this

The steps are mentioned below

  1. Type regedit in RUN or start menu search box and press Enter. It'll open Registry Editor.

  2. Now navigate to following key:

HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell

  1. Under "Shell" key, select "Bags" key and press "Delete" key. It'll ask for confirmation, click on Yes button.

  2. Now right-click on "Shell" key and select "New -> Key" option. Give the new key name of Bags

  3. Now right-click on "Bags" key and select "New -> Key" option. Give the new key name of AllFolders

  4. Again right-click on "AllFolders" key and select "New -> Key" option. Give the new key name of Shell

  5. Now click on this new "Shell" key and in right-side pane, create a new String value and give it name of FolderType and set its value to NotSpecified

share|improve this answer
I don't want to disable Automatic Folder Type Discovery. – Elmo Nov 5 '12 at 18:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.