Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Thunderbird E-mail client v. 2.0.0.23

I would like to filter all HTML encoded messages. For this I created a message filter with a customized header "Content-Type" but that does not work as expected (no messages are filtered).

The filter looks like that:

"Content-Type" "contains" "text/html"

I did not find any related bug or workaround (no add-ons).

Is my filter wrong? Should I try Thunderbird V. 3 beta?

share|improve this question
    
So this problem was my mistake, the filter is working, but as I am using an imap account, I needed to setup the account for offline use in order to be able to filter on the content-type (or for filtering on Body) –  avelldiroll Oct 2 '09 at 11:08

2 Answers 2

up vote 2 down vote accepted

For filters on the body of a message to work on an IMAP account, said account needs to be set up for offline use.

In order to do so go to:

Account settings > Offline & diskspace

and tick "Make the messages in my inbox available when I am working offline"

Then select the ad hoc folders after clicking on "Select folders for offline use ..."

After that my filter will work.

share|improve this answer

Any emails you receive in HTML format will contain the Content-type: text/html specification in the actual body of the message.

So change your filter to the following:

Body     contains     Content-type: text/html

This will now allow you to filter the emails sent in HTML.

share|improve this answer
    
Thanks, but as I commented above, I forgot to precise that I was using an imap account ... that means no online filtering on Body –  avelldiroll Oct 2 '09 at 11:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.