Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought this mouse in 2010, and since then, I have already used it on a lot of different computers.

Last month, I got a Samsung ultrabook with Windows 7 Home Premium, and I'm facing a problem which is driving me CRAZY.

My USB HID-compliant mouse (the dynex one), simply stops working when I lift it up and put it down back on the table. After I return it to the table, it takes like 1-3 seconds to back working.

I can also hear that Windows' sound when you unplug an USB device (lift), and the sound of plugging a new USB device (putting back to the table). After the sound, it backs to work, only after the sound.

After a research, I found Windows could be possibly disabling the USB to save battery of my notebook when I lift it, because Windows could find it's not being used anymore.

I already disallowed my windows to turn off USB Root Hub to save power (here). And I also already disabled the "USB selective suspend setting" (both "on battery" and "plugged in" on Control Panel\Power Options\Advanced power settings).

Someone knows anything else I can do to solve this? I already switched some mices I have here, and the problem refuses to stop.

share|improve this question
    
Just so I understand what you're saying in the last paragraph: You've tried this with mulitple mouses(mice) and had the same problem happen? Have you tried using different USB ports? If so, does the problem still happen? –  nageeb Dec 5 '12 at 21:00
    
If you go to Control Panel / Mouse / Hardware / Properties / Driver, is the the "Roll Back Driver" button greyed out ? –  harrymc Dec 6 '12 at 8:28
    
@harrymc the [Roll Back Driver] button is disabled –  BernaMariano Dec 6 '12 at 16:26
    
Ensure that there's no uncheckable "Allow the computer to disable this device to save power" box in Device Manager for the entries under "Mice and other pointing devices" and "Human Interface Devices." –  EKW Dec 11 '12 at 19:51
    
try installing mouse drivers/software... microsoft(intellipoint) and logitech mices come with ones...i don't which brand is yours.. –  tumchaaditya Dec 12 '12 at 15:57

2 Answers 2

up vote 0 down vote accepted
+100

The fact that the "Roll Back Driver" button is disabled means that you are still using the original generic Windows driver. However, Dynex does not supply a driver for this mouse, so you have no choice about it.

Some ideas to try :

First, ensure that you are totally patched-up in Windows Update, including optional updates.

Second, if you have a touchpad, make sure you have the latest drivers and try to "Disable internal pointing device when external USB pointing device is attached", similar to the way this is done in this article, if this does apply to the touchpad software on your computer.

Another idea is to go into the Device Manager, locate your mouse and delete it. Delete also any other displayed mouse. Then unplug the mouse, reboot and re-plug it. Create a system restore point just in case before you start. Let me know if this changes anything.

share|improve this answer

The cable is likely intermittent. It loses connection at one angle, and then connection is restored when you put it back to it's old angle. To confirm this, try another mouse in the same port. If that works, it's likely your mouse that is broken. Another test you could do is lift your mouse and the mouse-pad at the same time, if it breaks, then it's the cable, if no, then maybe there is something to your auto-disable theory after all.

share|improve this answer
    
I agree with Jikag, sounds like there is a bad connection somewhere, especially if you are hearing the USB connect/disconnect sound. Since I like to tinker with things I would open it up and see if you can't fix it yourself with some electrical tape or something. –  j_bombay Dec 5 '12 at 21:54
    
Also try same mouse in another port or another computer. –  harrymc Dec 6 '12 at 8:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.