Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The following code:

 include path/to/file

produces this error output:

... path/to/file: Permission denied

I ran:

cacls C: /t /g Everyone:R

so that the new permissions read:

                   <Account Domain not found>F 
                   Everyone:R 

It still says permission denied, but then I looked up my user name and it turns out I'm running as Administrator.

I ran:

cacls C: /t /g Administrator:F

but that had no effect on the cacls output

To my understanding, as administrator, the permissions shouldn't matter at all... What am I missing?

share|improve this question
    
I am accessing files from a unix filesystem through a windows machine. Could this be causing permission issues? –  Ocasta Eshu Nov 3 '12 at 21:31
    
Which operating system (windows machine?) And how are you accessing the windows machine? Through a "Windows Share" (aka SMB) you have two sets of 'permissions' on windows, and one of those is a smb permission the other is file level. You need to ensure that they match. The file permissions are permissive, the network (smb) permissions are restrictive. (Windows Version may impact this.) If you are accessing through telnet or ssh you have other things to consider. –  vgoff Nov 3 '12 at 21:45
    
The windows machine is XP. I am accessing the unix machine through Samba with W permission for other (I believe this is not being honored). I am accessing the windows machine through VNC which I believe uses SSH. –  Ocasta Eshu Nov 4 '12 at 19:59
    
This is very confusing. You state that you are accessing the Unix through SMB, and then accessing the Windows machine through VNC. Can you edit your question to show how you are connecting? A diagram may help. File permissions and the smb permissions will help, and the account will help. Try to express this in a way that doesn't use Root or Administrator user as being the active user (You likely shouldn't be connecting to a remote machine with accelerated privilege anyway). –  vgoff Nov 4 '12 at 20:54
add comment

1 Answer

up vote 1 down vote accepted

I couldn't really explain my situation any better, so I spoke to the system admin. He explained it thusly:

The windows user {w1} was associated with a user {u1} and I was trying to make actions that only user {u2} had the credentials to do.

*{u1}*     [Unix]      {u2}       

   |      --Samba--              

 {u1}      [Win1]           

          --VNC--                       

       [My Computer]                    

I couldn't do this without having a windows user associated with {u2}. So a quick solution would be to make my own windows user {w2}.

{u1}       [Unix]      {u2}       

   |      --Samba--      |        

 {w1}      [Win1]      {w2}   

          --VNC--                       

       [My Computer] 

But, Windows Virtual Machine, like all versions of windows (except Terminal Server) - can only support one user at a time. So to access {w2} I would have to log out user {w1} meaning the two users could not work simultaneously.

In the end, the solution was to create a cloned virtual machine [Win2] associated with user {u2} so that both users could work simultaneously.

  {u1}      [Unix]      {u2}

           --Samba--    

    [Win1]          [Win2]

            --VNC--

         [My Computer]
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.