Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows, there's this automatic metric thing where the metric is selected according to the declared speed of the link. I now have a gigabit LAN routed to a 2Mbps DSL service and a HSDPA mobile broadband connection. The former is always chosen for Internet packets even though the latter is actually faster.

I tried setting the mobile broadband's interface metric to 1 and raising its priority in the advanced settings of the adapter settings, but this does not seem to affect the metric of the default route. The default route to the Ethernet interface always have a lower "effective" metric than the mobile broadband interface (i.e. it is used even if it has a higher metric).

Am I missing something here?

Edit:

Interfaces:

Idx     Met         MTU          State                Name
---  ----------  ----------  ------------  ---------------------------
 13           9        1500  connected     Mobile broadband
 12          25        1500  disconnected  WiFi 2
  1          50  4294967295  connected     Loopback Pseudo-Interface 1
 20           5        1500  disconnected  Local Area Connection* 12
 24          10        1500  connected     Ethernet

Edit 2:

The strange routing behaviour returned today:

Routing table:

Publish  Type      Met  Prefix                    Idx  Gateway/Interface Name
-------  --------  ---  ------------------------  ---  ------------------------
No       Manual    512  0.0.0.0/0                  24  192.168.1.254
No       Manual    0    0.0.0.0/0                  12  192.168.135.1
No       Manual    256  0.0.0.0/0                  13  188.*.*.*

Idx 12 is the fastest link. Idx 24 is the slowest. The route metric of the idx 24 route was manually adjusted up. However, trace route showed this:

C:\Users\bc>tracert -4 -d google.com

Tracing route to google.com [173.194.41.168]
over a maximum of 30 hops:

  1     2 ms     2 ms     3 ms  192.168.1.254
  2    25 ms    24 ms    26 ms  217.*.*.*
  3    27 ms    26 ms    36 ms  217.*.*.*

This seems to suggest for routes with the same destination, the metrics are not used.

Further more, it seems the metrics are only respected in the first trace route after a connection has been brought up. The next trace route will consistently show the Ethernet connection (idx 24) as the first hop.

share|improve this question
1  
why don't you print your routing table so people can visualize what you are talking about. make sure you mark the routes which 'don't work' –  Boppity Bop Nov 9 '12 at 22:48
    
You could try Connectify Dispatch I guess –  pratnala Nov 20 '12 at 13:36
add comment

2 Answers

The short anwer is NO, you cannot route packets based on metrics when using a "dial up" connection and your HSDPA connection is classified as dial up connection.


Microsoft routes all IP packets via DuN if established and will fence off the local network to prevent external dial up intruders from invading your DSL/Gb LAN.

This legacy design was implemented in the mid 1990's and is useless but it deeply embedded into your networking stack that either 3rd party routerware or Internet Connection Sharing tweaks will be required to circumvent and accomplish what you're trying to do.

A connection profile manager is also a good choice such as IBM/Lenovo's Access Connections Manager which detects all existing connections and uses the fastest, but I've never tried installing it onto anything but a ThinkPad and unaware if it will function on any laptop or would be compatible with your 3G adapter and drivers. Microsoft may offer a connectiopn profile manager but I'm ignorant of one nor would presumptuously claim to be aware of all Microsoft software.

Typically, Windows DialUpNetworking equipped users have accepted this design and consciously disconnected their DuN connection when using a LAN, more than likely you've discovered this too.

Your question begs a follow up as to why is it necessary for you to mount two or more simultaneous IP connections via your LAN and 3G. I hope you don't foolishly believe you can actually etherchannel the connections to increase your bandwidth.

Another reason I'm speculating about your intent is possibly to simultaneously download from a limiting site like Rapidshare that would only allow one file transfer at a time, if that is the case then you should use two different browsers and set IE to use only your 3G dial up connection while another browser like Firefox to use only the LAN and this would enable you to download your big porn / pirated movie files two at a time.

share|improve this answer
1  
I am very conscious about what I can and can't do by having multiple connections. In this case, I want to access resources on the LAN and get faster Internet via mobile broadband. However, what I am observing seems to be exactly opposite to what you described here: the packets are constantly routed via the Ethernet connection as opposed to the mobile broadband. –  billc.cn Nov 18 '12 at 14:57
    
Yes thats right, your "so conscious" about what is possible on a LAN that you're still unable to circumvent the long standing design of Windows. –  Eagle Spear Nov 19 '12 at 11:50
add comment

Before messing with metric you should always check if both ways work (e.g. disconnecting each one and test if all still works). In your case I assume everthing is fine with this.

If everything works and both connections can handle your packages the metric is used to determine which interface to use. If I mess with the metrics I prefer to disable auto metric for every interface and handle it by myself, but you could also look up the values used by auto metric in KB299540. I don't recommend this, because you never know for sure if something changes in the future or Windows decides a connection is from a better or worse qualitiy.

The connection with the lowest metric should get used for sending the packages. If it does not, try a reboot. If it still does not work, then

a) you misconfigured something;

b) a connection that (in your opinion) should route your packages is unable to route them.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.